Texture completely broken (SOLVED)

Started by davtov on Thu, 12/12/2019 - 18:30

Topic category: Help with MCreator software

Last seen on 18:54, 27. Jun 2020
Joined Dec 2019
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Texture completely broken (SOLVED)
Thu, 01/02/2020 - 13:00 (edited)

I made a model with blockbench and the model works perfectly. I also exported the texture from Blockbench and I used the texture with the model in MCreator and it is simply not working. The texture is either the purple and black missing texture thing or a mix of the missing texture and my texture, just a zoomed out version, please help!

Edited by davtov on Thu, 01/02/2020 - 13:00
Last seen on 10:14, 27. Sep 2020
Joined Apr 2010
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
The solution to this problem…
Fri, 12/13/2019 - 08:42

The solution to this problem and many other problems can be found in our knowledge base: https://mcreator.net/support/knowledgebase Please check the knowledge base before opening a new topic on the issue which has a known fix.

Last seen on 18:54, 27. Jun 2020
Joined Dec 2019
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Apologies for the late reply…
Wed, 01/01/2020 - 22:42

Apologies for the late reply, but I checked the Knowledgebase and none of the solutions seem to work. I still cannot fix my texture, any other advice?

Last seen on 18:54, 27. Jun 2020
Joined Dec 2019
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Here you go, I hope I did it…
Thu, 01/02/2020 - 12:24

Here you go, I hope I did it right. https://pastebin.com/XsWrUx5u

Last seen on 10:14, 27. Sep 2020
Joined Apr 2010
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Please paste the contents of…
Thu, 01/02/2020 - 12:38

Please paste the contents of the console tab when you see a broken texture as the model seems fine.

One thing to check is that all model textures are square in size (16x16, 32x32, ...).

Last seen on 18:54, 27. Jun 2020
Joined Dec 2019
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
The texture is 32x32, so…
Thu, 01/02/2020 - 12:54

The texture is 32x32, so that can't be the issue. When do I need to paste the console tab? I mean, after exporting the mod, or..?

Last seen on 18:54, 27. Jun 2020
Joined Dec 2019
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
I just solved the issue…
Thu, 01/02/2020 - 13:00

I just solved the issue. Turns out, I forgot to add both Parts to the texture mapping and only added one. I'm sorry for wasting your time.