Porting mod from 1.12.2 to 1.14.4 - mod crashes on start

Started by Oravaliito on Thu, 02/13/2020 - 23:27

Topic category: Help with MCreator software

Last seen on 15:29, 14. Feb 2020
Joined Feb 2016
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Porting mod from 1.12.2 to 1.14.4 - mod crashes on start
Thu, 02/13/2020 - 23:27

Hello. I need help in porting my mod from 1.12.2 to 1.14.4 without having to start over creating from scratch if that is possible anymore unless changing the version broke the mod.
My mod worked fine on 1.12.2 and then I changed version of export to 1.14.4 and after that I keep getting this error at start if I do not make any changes:
Error

Is there anything I can do in the program to keep it working or should I just start over with 1.14.4?
Only thing I got from that is that it has something to do with Skye's Bakery Logo and I deleted it and made again but same error keeps happening. Any help appreciated.

Last seen on 13:32, 1. Oct 2020
Joined Jun 2019
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
no offense but can you…
Fri, 02/14/2020 - 00:21

no offense but can you actually search on this website for your issue?

Everyone is having the same issue and it has a known fix!!! >:(

https://mcreator.net/wiki/minecraft-1144-resourcelocationexception-non-z0-9-character-path-location

Last seen on 15:29, 14. Feb 2020
Joined Feb 2016
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
I searched but none of the…
Fri, 02/14/2020 - 02:55

I searched but none of the titles reminded me about it being about this problem. I also don't have time to enter every post and see them through. So I briefly went through some posts but found no result. No need to get angry about it..

Last seen on 15:29, 14. Feb 2020
Joined Feb 2016
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
But thanks for this link.
Fri, 02/14/2020 - 02:56

But thanks for this link.

Last seen on 17:34, 14. Sep 2020
Joined Dec 2017
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
the error sounds like you…
Fri, 02/14/2020 - 05:52

the error sounds like you put a character that's not alphanumeric, specifically the ' character in your mod name. idk if thats the case but if error names are proper but if they are its most likley that

Last seen on 17:34, 14. Sep 2020
Joined Dec 2017
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
wait ok i didn't read…
Fri, 02/14/2020 - 06:01

wait ok i didn't read properly. what shows as the problem of the error after you deleted that?

Last seen on 13:32, 1. Oct 2020
Joined Jun 2019
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
@Orvaliito sry I'm just…
Fri, 02/14/2020 - 06:05

@Orvaliito

sry I'm just annoyed that so many people are asking the same question

Last seen on 15:29, 14. Feb 2020
Joined Feb 2016
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
I understand. I just…
Fri, 02/14/2020 - 15:30

I understand. I just personally didn't find any relevant post about this for brief lookout so I decided to make the post.