3D armor Help needed(model is made i just got a few bugs)

Started by Darth Feanor on Mon, 03/09/2020 - 19:10

Topic category: Help with modding (Java Edition)

Last seen on 21:28, 29. Mar 2020
Joined Apr 2019
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
3D armor Help needed(model is made i just got a few bugs)
Mon, 03/09/2020 - 19:10

Alright, hello reader! So, I am making a armor set that will use a custom 3d model I have made. Said model was working before, but then i added some textures to it and a few more blocks in the model and the chest(torso) works just great, with a bug stated further down. However the main issue is the arms, the arms have models as well but they refuse to show ingame. So I guess in a list, the bugs would be these:

  • Torso: when you walk/jump its fine but it offsets from the player when you crouch.
  • Arms: neither render ingame, just confused as to why this would be.

All I have made so far is a chest piece, so further issues may arise with later armor parts but for now this is what I got.

If someone(s) could help me with this I would be very grateful!

Last seen on 15:46, 28. Nov 2020
Joined May 2018
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
The arms dont show up…
Fri, 03/20/2020 - 04:27

The arms dont show up because they arent animated so fixing that would just be animating the arms and they should show up, for the chest im not sure but you could try comparing if the rotation point of the main chest block is the same as the player model