I need help with custom model

Started by stefanicak on Tue, 05/26/2020 - 14:16

Topic category: Help with MCreator software

Last seen on 22:35, 31. Jul 2021
Joined May 2020
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
I need help with custom model
Tue, 05/26/2020 - 14:16 (edited)

every time when i try use custom model its do this error:

 

 

Executing Gradle task: build
Build info: MCreator 2020.2.14217, 1.14.4, 64-bit, 16329 MB, Windows 10, JVM 1.8.0_232, JAVA_HOME: C:\Program Files\Pylo\MCreator\jdk
> Configure project :
New Dep: net.minecraftforge:forge:1.14.4-28.2.3_mapped_snapshot_20190719-1.14.3
> Task :compileJava FAILED
C:\Users\stefanicak\MCreatorWorkspaces\firstmod\src\main\java\net\mcreator\firstmod\entity\GolemStage1Entity.java:166: error: cannot find symbol       public void render(MatrixStack matrixStack, IVertexBuilder buffer, int packedLight, int packedOverlay, float red, float green, float blue,
                         ^
  symbol:   class MatrixStack
  location: class Modelgolem1
C:\Users\stefanicak\MCreatorWorkspaces\firstmod\src\main\java\net\mcreator\firstmod\entity\GolemStage1Entity.java:166: error: cannot find symbol       public void render(MatrixStack matrixStack, IVertexBuilder buffer, int packedLight, int packedOverlay, float red, float green, float blue,
                                                  ^
  symbol:   class IVertexBuilder
  location: class Modelgolem1
2 errors
FAILURE: Build failed with an exception.
* What went wrong:
Execution failed for task ':compileJava'.
> Compilation failed; see the compiler error output for details.
* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.
* Get more help at https://help.gradle.org
Deprecated Gradle features were used in this build, making it incompatible with Gradle 5.0.
Use '--warning-mode all' to show the individual deprecation warnings.
See https://docs.gradle.org/4.9/userguide/command_line_interface.html#sec:c…
BUILD FAILED in 3s
1 actionable task: 1 executed
BUILD FAILED
Task completed in 5676 milliseconds
 

 

 

please help me, what do with this and make my custom model for entity work

Edited by stefanicak on Tue, 05/26/2020 - 14:16
Seems like a problem with…
Tue, 05/26/2020 - 14:53

Seems like a problem with mob model versions

Are you using models from a different version than your mod?

Last seen on 20:39, 25. Jul 2021
Joined Jul 2017
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
You can get 2020.3 that…
Sun, 06/28/2020 - 02:10

You can get 2020.3 that solved most block bench import problems