Translucent Block Xrays through the ground?

Started by Finmide on Mon, 07/06/2020 - 20:53

Topic category: Help with modding (Java Edition)

Last seen on 02:10, 4. Aug 2020
Joined Aug 2019
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Translucent Block Xrays through the ground?
Mon, 07/06/2020 - 20:53

Translucent Block causing Xray through ground.

 

So um I was testing something with a block I made and when I placed it I learned that it causes this little problem. How do I fix this?

Last seen on 19:25, 8. Aug 2020
Joined Jun 2020
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
turn off enable connected…
Tue, 07/07/2020 - 15:17

turn off enable connected sides if its on

Last seen on 02:10, 4. Aug 2020
Joined Aug 2019
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
It is not on is there other…
Fri, 07/10/2020 - 12:55

It is not on is there other suggestions?

Last seen on 17:27, 7. Aug 2020
Joined Jun 2016
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Enable transparency
Fri, 07/10/2020 - 13:17

Enable transparency

Last seen on 02:10, 4. Aug 2020
Joined Aug 2019
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Transparency is enabled
Fri, 07/10/2020 - 13:24

Transparency is enabled

Last seen on 17:27, 7. Aug 2020
Joined Jun 2016
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Could you paste here some…
Sat, 07/11/2020 - 08:13

Could you paste here some images about the settings you used for the block and how it is rendered ingame?

Last seen on 02:10, 4. Aug 2020
Joined Aug 2019
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Here is the setting page for…
Sat, 07/11/2020 - 22:51

Here is the setting page for the block:

Block Setting

 

And how it appears in game when testing:

In Game Test

 

Last seen on 17:27, 7. Aug 2020
Joined Jun 2016
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
No idea then :( It might be…
Sun, 07/12/2020 - 13:42

No idea then :(

It might be an MCreator bug, try opening an issue on the tracker about it

Last seen on 02:10, 4. Aug 2020
Joined Aug 2019
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
So I fixed it from x-raying…
Sun, 07/12/2020 - 20:13

So I fixed it from x-raying by turning on both translucency and connected sides.

 

However whenever transparency is active I notice it creates a new problem in the world the block naturally spawns in. (I tested it and connected sides doesn't affect it)

 

So this is the appearance I get when I have transparency off

 

Transparency off

 

And then when I turn on transparency This happens

 

Transparency On

 

 

 

of course I am going for the above appearance as its supposed to look eerie and plus after the change it causes some graphical errors as you may be able to see in the corner.

 

Last seen on 17:27, 7. Aug 2020
Joined Jun 2016
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Is the opacity set to 0?
Thu, 07/16/2020 - 19:35

Is the opacity set to 0?

Last seen on 02:10, 4. Aug 2020
Joined Aug 2019
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
The opacity is set to 255…
Sun, 08/02/2020 - 14:34

The opacity is set to 255 but I tried 0 and 1 and it still does this..