problem with custom entity compilation

Started by JowoJo on Wed, 08/26/2020 - 13:20

Topic category: Help with MCreator software

Last seen on 19:19, 22. Oct 2020
Joined Aug 2020
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
problem with custom entity compilation
Wed, 08/26/2020 - 13:20

i have a problem when i try to make an compilation with an custom entity (custom model, custom texture)
I have this error :

Executing Gradle task: build 
Build info: MCreator 2020.2.14217, 1.12.2, 64-bit, 16307 MB, Windows 10, JVM 1.8.0_232, JAVA_HOME: D:\ooamod\pylo\jdk 
This mapping 'snapshot_20171003' was designed for MC 1.12! Use at your own peril. 
:deobfCompileDummyTask 
:deobfProvidedDummyTask 
:sourceApiJava UP-TO-DATE 
:compileApiJava NO-SOURCE 
:processApiResources NO-SOURCE 
:apiClasses UP-TO-DATE 
:sourceMainJava 
D:\ooamod\odyssecraftmod\build\sources\main\java\net\mcreator\ocmd\entity\EntityDeer.java:58: error: constructor EntityDeer in class EntityDeer cannot be applied to given types; 
         return new RenderLiving(renderManager, new EntityDeer(), 0.5f) { 
                                                ^ 
  required: ElementsOdyssecraftmod 
  found: no arguments 
  reason: actual and formal argument lists differ in length 
1 error 
:compileJava FAILED 
FAILURE: Build failed with an exception. 
* What went wrong: 
Execution failed for task ':compileJava'. 
> Compilation failed; see the compiler error output for details. 
* Try: 
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights. 
* Get more help at https://help.gradle.org 
BUILD FAILED in 9s 
5 actionable tasks: 4 executed, 1 up-to-date 
BUILD FAILED 
Task completed in 12617 milliseconds

 

Last seen on 18:05, 14. Sep 2020
Joined Apr 2020
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
This mapping 'snapshot…
Wed, 08/26/2020 - 15:33

This mapping 'snapshot_20171003' was designed for MC 1.12! Use at your own peril.

It can't build the mapping because it was made for a different version of minecraft then the one you are using. Update the mapping to the version you are using, or remake it. Hope this helps!

Last seen on 19:19, 22. Oct 2020
Joined Aug 2020
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
how can i change the mapping…
Wed, 08/26/2020 - 22:46

how can i change the mapping setting ? im on blockbench

Last seen on 04:38, 20. Oct 2020
Joined Jun 2019
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
  Build info: MCreator 2020…
Thu, 08/27/2020 - 00:17

 

Build info: MCreator 2020.2.14217, 1.12.2, 64-bit, 16307 MB, Windows 10, JVM 1.8.0_232, JAVA_HOME: D:\ooamod\pylo\jdk

Update please... 

Last seen on 19:19, 22. Oct 2020
Joined Aug 2020
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Update please...  i will…
Thu, 08/27/2020 - 11:49

Update please... 

i will not, im on 1.12.2 Forge server, and i know than later version dosent support 1.12.2 version

Last seen on 19:19, 22. Oct 2020
Joined Aug 2020
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
i'v find and change the…
Thu, 08/27/2020 - 12:39

i'v find and change the version of export my models but i have the same error.

but  this have change nothing...

Last seen on 04:38, 20. Oct 2020
Joined Jun 2019
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
than good luck, nobody here…
Fri, 08/28/2020 - 01:33

than good luck, nobody here will support outdated versions 

Last seen on 19:19, 22. Oct 2020
Joined Aug 2020
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
than good luck, nobody here…
Fri, 08/28/2020 - 11:46

than good luck, nobody here will support outdated versions 
 

i dont search people who support outdated version, i want an solution for make an entity in this version.
 

Last seen on 18:05, 14. Sep 2020
Joined Apr 2020
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
It may come down to you…
Sun, 08/30/2020 - 03:14

It may come down to you needing to delete the element and remaking it... Hopefully that solves the problem.

Last seen on 19:19, 22. Oct 2020
Joined Aug 2020
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
i have already do this, look…
Sun, 08/30/2020 - 10:02

i have already do this, look at my replie at "i'v find and change the…Thu, 08/27/2020 - 12:39"
this is another entity, it doing the same thing

Last seen on 13:37, 22. Oct 2020
Joined Jan 2019
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
As they said, please Update…
Sun, 08/30/2020 - 10:08

As they said, please Update. If you really want 1.12.2, then download the plugin.

Last seen on 19:19, 22. Oct 2020
Joined Aug 2020
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
As they said, please Update…
Fri, 09/04/2020 - 12:31

As they said, please Update. If you really want 1.12.2, then download the plugin.

witch plugin ?

Last seen on 01:43, 23. Oct 2020
Joined May 2019
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Hello JowoJo We understand…
Fri, 09/04/2020 - 12:49

Hello JowoJo

We understand that you are having a problem with 1.12 entity models in MCR 2020.2

In this case, we urge you to understand that Mcreator 2020.2 you are using is a deprecated version by Pylo, and will no longer be supported. Please, upgrade to the current version 2020.4 here: https://mcreator.net/download/2020-4

Then, you can head over to the 1.12 legacy plugin page here: https://mcreator.net/plugin/64513/minecraft-1122-generator

Download the plugin zip and head over to Mcreator>Preferences>Manage Plugins>Add plugin>Select Zip File

You should also understand that the 1.12 plugin is no longer supported by Pylo, nor is 1.12 as a version supported by forge anymore

 

Best