Game crashes whenever i put my armor on because of my procedure. Any fixes/ideas?

Started by NightCog on Thu, 09/10/2020 - 20:21

Topic category: Help with MCreator software

Last seen on 17:42, 3. Oct 2020
Joined Sep 2020
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Game crashes whenever i put my armor on because of my procedure. Any fixes/ideas?
Thu, 09/10/2020 - 20:21

Hey y'all! So i have made some armor, that "tries" to give you a slowness effect whenever you put any part of the armor onto your player. Except that, it doesn't work and it freezes the game.

Here are some photos of the procedures:

https://prnt.sc/uf5hu4

https://prnt.sc/uf5i36

https://prnt.sc/uf5i5w

https://prnt.sc/uf5ibd

Here is the crash report: https://pastebin.pl/view/fd4beac2

Last seen on 12:01, 31. Oct 2020
Joined Sep 2019
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
For one, the armour slots…
Fri, 09/11/2020 - 04:09

For one, the armour slots are numbered 100-103

https://static.wikia.nocookie.net/minecraft_gamepedia/images/b/b2/Items…

(Embed image wouldn't work)

It may be a problem with MCreator, try regenerating and building the code again (the little bandage icon). Does this happen in other workspaces?

Last seen on 17:42, 3. Oct 2020
Joined Sep 2020
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Putting the armor slots to…
Fri, 09/11/2020 - 07:51

Putting the armor slots to 100-103 did not fix the problem. Neither did the "bandage" icon. For anyone who is having this problem, to fix it, you need to put the helmet slot number to 3, chestplate to 2, leggings to 1 and boots to 0. There was a small information box which said that, but apparently i did not see it yesterday. Thank you for answering, anyway!