Dimensions do not function correctly

Started by BunnyLord_123 on Sat, 09/19/2020 - 00:23

Topic category: Bugs and solutions

Last seen on 20:52, 25. Sep 2020
Joined Feb 2019
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Dimensions do not function correctly
Sat, 09/19/2020 - 00:23

When I have a dimension and then try to test my mod, the gradle says that there are errors relating to the dimension. I don't know what they possibly could be, so I'm not sure how to fix it.

Last seen on 04:38, 20. Oct 2020
Joined Jun 2019
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
log please...
Sat, 09/19/2020 - 01:17

log please...

Last seen on 20:52, 25. Sep 2020
Joined Feb 2019
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
here   Executing Gradle task…
Sat, 09/19/2020 - 01:45

here

 

Executing Gradle task: build
Build info: MCreator 2020.4.32115, forge-1.15.2, 64-bit, 3981 MB, Windows 10, JVM 1.8.0_252, JAVA_HOME: C:\Program Files\Pylo\MCreator\jdk
> Configure project :
New Dep: net.minecraftforge:forge:1.15.2-31.2.0_mapped_snapshot_20200514-1.15.1
> Task :compileJava
C:\Users\[my name]MCreatorWorkspaces\skies_of_ender\src\main\java\net\mcreator\skiesofender\world\dimension\DeepEndDimension.java:134: error: illegal start of type }
^
C:\Users\[my name]\MCreatorWorkspaces\skies_of_ender\src\main\java\net\mcreator\skiesofender\world\dimension\DeepEndDimension.java:135: error: illegal start of expression @SubscribeEvent
^
C:\Users\[my name]\MCreatorWorkspaces\skies_of_ender\src\main\java\net\mcreator\skiesofender\world\dimension\DeepEndDimension.java:135: error: ';' expected @SubscribeEvent
^
C:\Users\[my name]\MCreatorWorkspaces\skies_of_ender\src\main\java\net\mcreator\skiesofender\world\dimension\DeepEndDimension.java:196: error: reached end of file while parsing }
^
4 errors
> Task :compileJava FAILED
FAILURE: Build failed with an exception.
* What went wrong:
Execution failed for task ':compileJava'.
> Compilation failed; see the compiler error output for details.
* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.
* Get more help at https://help.gradle.org
Deprecated Gradle features were used in this build, making it incompatible with Gradle 5.0.
Use '--warning-mode all' to show the individual deprecation warnings.
See https://docs.gradle.org/4.10.3/userguide/command_line_interface.html#se…
BUILD FAILED in 3m 41s
1 actionable task: 1 executed
BUILD FAILED
Task completed in 254268 milliseconds
 

Last seen on 01:01, 19. Oct 2020
Joined Sep 2019
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Says "Deprecated Gradle…
Sat, 09/19/2020 - 02:19

Says "Deprecated Gradle features were used in this build, making it incompatible with Gradle 5.0"

Did you turn off Gradle updating ?

Last seen on 01:01, 19. Oct 2020
Joined Sep 2019
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Nvm sorry
Sat, 09/19/2020 - 02:46

Nvm sorry