Attack player AI block is not working

Started by Volga56 on Wed, 10/14/2020 - 15:08

Topic category: Troubleshooting, bugs, and solutions

Last seen on 17:05, 16. Sep 2021
Joined Mar 2020
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Attack player AI block is not working
Wed, 10/14/2020 - 15:08

I know there is another topic about this, but this is for Mcreator 2020.4 and forge 1.15.2. I made a mob that looks like an enderman and does not use an enderman base (or any other AI base). It is supposted to attack a player on sight, but it just stands there until attacked. Even after it is attacked, it just stands there and waits for the player to come close to it. What am I doing wrong? (I can send images later)

Last seen on 18:49, 13. May 2021
Joined May 2019
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Is walking enabled? You…
Wed, 10/14/2020 - 18:41

Is walking enabled? You might have to introduce a block in the procedures that "enables walking." I believe its refers to wandering.

Last seen on 17:05, 16. Sep 2021
Joined Mar 2020
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Okay. I will check if I did…
Thu, 10/15/2020 - 01:10

Okay. I will check if I did later

Last seen on 17:05, 16. Sep 2021
Joined Mar 2020
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Thank you in advance!
Thu, 10/15/2020 - 01:10

Thank you in advance!

I suggest you check our…
Thu, 10/15/2020 - 08:10

I suggest you check our tutorials collection playlist on our YouTube channel which contains many examples and tutorials that can help you get started with MCreator: https://www.youtube.com/playlist?list=PLAeL-oIFIEngE6jRgFYeFMfuj8WQsO3Ei

Last seen on 17:05, 16. Sep 2021
Joined Mar 2020
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Ah I found it out. For some…
Mon, 02/15/2021 - 20:12

Ah I found it out. For some reason I checked "Water entity" when it was a land entity