Problem with the trigger "when a block is broken"

Started by Solmonaar on Wed, 11/18/2020 - 19:06

Topic category: Help with modding (Java Edition)

Last seen on 15:47, 20. Sep 2021
Joined Nov 2020
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Problem with the trigger "when a block is broken"
Wed, 11/18/2020 - 19:06

I can't place a block when a specific block is break.

 

I make a procedure with the trigger when a block is broken then I said if get block at ~ ~ ~ = to oak_leaves do place custom_block at ~ ~ ~ and it doesn't work.

Last seen on 06:55, 27. Apr 2021
Joined Dec 2017
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
I was going to try to help…
Thu, 11/19/2020 - 08:20

I was going to try to help you, but you're right it doesn't work and I don't know how to make it work..

Also, only Blocks don't work, if you pick a flower or plant to spawn, they will spawn in already popped..

Last seen on 06:55, 27. Apr 2021
Joined Dec 2017
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
and if you do +1 or -1 for Y…
Thu, 11/19/2020 - 08:23

and if you do +1 or -1 for Y, those spawn correctly..

Last seen on 15:47, 20. Sep 2021
Joined Nov 2020
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
thx
Thu, 11/19/2020 - 15:41

thx