My structure doesnt want to generate / crashes minecraft

Started by MMG on Sat, 01/23/2021 - 10:01

Topic category: Help with modding (Java Edition)

Last seen on 12:28, 16. May 2022
Joined Oct 2017
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
My structure doesnt want to generate / crashes minecraft
Sat, 01/23/2021 - 10:01

So. I have a structure which is randomly generated by procedure. When I generate it using command it works perfectly, but when its generated naturally, game gets a permanent lagspike. You can still move arround but everything is stopped and chunks are not generating. What should I do? I tryed almost all possible things, I even tryed to make strucutre smaller. When it was smaller it didnt crashed the game but it didnt even generated. I dont really know what to do, please help

Did you check the crash log?…
Sat, 01/23/2021 - 10:22

Did you check the crash log? Include it so we can try to help.

Last seen on 12:28, 16. May 2022
Joined Oct 2017
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
there is actually no crash…
Sat, 01/23/2021 - 14:25

there is actually no crash log, game just stops functioning, you can still move, but you cant place, or break, mobs are not moving or doing anything, nothing generates. Its like TPS goes to 0

Last seen on 12:28, 16. May 2022
Joined Oct 2017
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Should I sent you workspace?
Sat, 01/23/2021 - 16:05

Should I sent you workspace?

This will be very hard to…
Mon, 01/25/2021 - 08:44

This will be very hard to debug. Yes, please, but open an issue on GitHub so other contributors can take a look too