My mod won't work on a server

Started by EgoBoost on Wed, 04/28/2021 - 01:30

Topic category: Troubleshooting, bugs, and solutions

Last seen on 20:08, 7. Jun 2021
Joined Apr 2021
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
My mod won't work on a server
Wed, 04/28/2021 - 01:30

Hey, so i've got a pretty decent issue in my hands. I'm trying to develop a mod called My Titan which is mainly a multiplayer mod, I have tested it consistently in the intergrated server testing you guys have, and it works fine. However when I try to add the mod to any forge server (ive tried multiple times in multiple hosts) it won't work. It's as if the mod isn't even loaded onto the server, but it actually is, since it gives this error message in the console. Also, yes I did add all my dependencies to the server, I also checked in the thread about making a mod multiplayer compatible, and my mod doesn't seem to have any of those issues. The mod also works perfectly fine when exported into a single player world, and i also added another mod to make sure it wasn't the server making issues and sure enough, the other mod worked fine, but even after removing that mod, it never worked. I have no idea what to do. I hope you can provide some support.

Last seen on 20:08, 7. Jun 2021
Joined Apr 2021
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Also worth mentioning, i've…
Wed, 04/28/2021 - 01:31

Also worth mentioning, i've tried exporting it multiple times, and i've tried regenerating the code multiple times.

Last seen on 20:08, 7. Jun 2021
Joined Apr 2021
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Also, i'm using the…
Wed, 04/28/2021 - 01:33

Also, i'm using the goldsfucate plugin if that helps in any way, i'm on version 2020.5 (waiting for goldsfucate to update since my mod relies on it) and i'm on mc 1.15.2

Last seen on 16:51, 21. Jun 2021
Joined Mar 2020
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
me too i have the same…
Mon, 05/31/2021 - 19:41

me too i have the same problem