Dimensions not loading in 1.16.5

Started by PythonIsCool on Fri, 04/30/2021 - 21:46

Topic category: Troubleshooting, bugs, and solutions

Last seen on 23:41, 3. Jun 2021
Joined Dec 2019
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Dimensions not loading in 1.16.5
Fri, 04/30/2021 - 21:46

public  class TeleporterDimensionMod implements ITeleporter {

    private final ServerWorld world;
    private final BlockPos entityEnterPos;

    public TeleporterDimensionMod(ServerWorld worldServer, BlockPos entityEnterPos) {
        this.world = worldServer;
        this.entityEnterPos = entityEnterPos;
    }

it says class is spelled wrong (has the little red squiggly line) so can you guys give me advice on what's wrong

In some cases, Gradle caches…
Sat, 05/01/2021 - 08:17

In some cases, Gradle caches that make sure the build process does not take too long can get corrupted. In such a case, go to:

<your user home folder>/.mcreator/gradle

In this folder, there is a folder called caches. Delete this folder and open MCreator again. Next build will take a bit longer as caches need to be rebuilt. If you can not delete all files in this folder (which is necessary), reboot the computer first to remove any potential file locks.

If this is not enough to make things work, delete the entire gradle folder, not just caches, and try again.

If even this fails, try to delete the entire <your user home folder>/.mcreator/gradle folder, create a new workspace with the same generator version as the version of the workspace failing, after the setup of this new workspace is done, open your current workspace, and click Build & run -> Build workspace, then Build & run -> Reload gradle project and then Build & run -> Regenerate code and build.

Last seen on 23:41, 3. Jun 2021
Joined Dec 2019
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
so ive been sitting here for…
Sat, 05/01/2021 - 14:41

so ive been sitting here for about 30 minutes and it's still setting up the new workspace (I took the 3rd option). it still hasn't finished. is this normal

Last seen on 23:41, 3. Jun 2021
Joined Dec 2019
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
it finished and didnt work…
Sat, 05/01/2021 - 14:56

it finished and didnt work at all. honestly, I dont care anymore and I'll just delete the dimensions. Not like I needed them anyways.