Found A Bug in MCreator 2021.2 2nd Snapshot

Started by Skiizy on Sun, 06/27/2021 - 02:21

Topic category: Troubleshooting, bugs, and solutions

Last seen on 02:05, 2. Jul 2021
Joined Mar 2021
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Found A Bug in MCreator 2021.2 2nd Snapshot
Sun, 06/27/2021 - 02:21

Found A Bug in MCreator 2021.2 2nd Snapshot, I cant create a new world every time I test the mod....

Every time I create a world it only says "Error in currently selected datapacks prevented the world from loading. you can either try to load it with only the vanilla datapack ("safemode"), or go back to the title screen and fix it manually"

There's two button that says safe mode and back to title screen. Every time I press safe mode nothing happens and if I press back to title screen it goes back to title screen and thats it I cant test my mod

In some cases, Gradle caches…
Sun, 06/27/2021 - 08:02

In some cases, Gradle caches that make sure the build process does not take too long can get corrupted. In such a case, go to:

<your user home folder>/.mcreator/gradle

In this folder, there is a folder called caches. Delete this folder and open MCreator again. Next build will take a bit longer as caches need to be rebuilt. If you can not delete all files in this folder (which is necessary), reboot the computer first to remove any potential file locks.

If this is not enough to make things work, delete the entire gradle folder, not just caches, and try again.

If even this fails, try to delete the entire <your user home folder>/.mcreator/gradle folder, create a new workspace with the same generator version as the version of the workspace failing, after the setup of this new workspace is done, open your current workspace, and click Build & run -> Build workspace, then Build & run -> Reload gradle project and then Build & run -> Regenerate code and build.

The solution to this problem and many other problems can be found in our knowledge base: https://mcreator.net/support/knowledgebase Please check the knowledge base before opening a new topic on the issue which has a known fix.