[QUESTION]I came back to Mcreator after months or maybe even years and i have a question

Started by Lliakos on Fri, 07/16/2021 - 14:07

Topic category: General discussion

Last seen on 12:14, 19. Jul 2021
Joined May 2019
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
[QUESTION]I came back to Mcreator after months or maybe even years and i have a question
Fri, 07/16/2021 - 14:07

So i came back after a year or idk and i have a question is there a way to let me mod for 1.12.2 and still have all the new features? Like i downloaded the lates version thinking it would let me mod for 1.12.2 but it didnt wich (pls idk how to write wich, whitch) is ok but it would sitll have none of the new features so is there a way to have the latest version but still mod for 1.12.2? Also can i edit a mod of mine without having the .mcreator file (edit a workspace) Cause i changed 3 laptops and yea i dont have any of my workspaces.

Last seen on 16:53, 25. Jul 2021
Joined Jul 2021
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Wait, I found a possible…
Fri, 07/16/2021 - 17:33

Wait, I found a possible solution:

First you need to decompile your mod. You can download some decompiler, or you can use some online (but these usually have some limitations or some other issues).
Now you have your decompiled mod, the main problem now is that all Minecraft names of fields, methods, and classes are obfuscated. You have to get MCP mappings of your MCreator and translate them manually or you can use for example  mcpbot  to getting the translated names. Also, there is a third most likely third option of using a tool that should do the work for you. 
The final step is going to be most likely getting these files to MCreator. There are few places where you have to put them. Also in some locations you need .class files, and in some .java files.

The problem with this is (1) It won't come out the same and there would be hundreds of issues with the jar compression and (2) It will be a long process.

But you can try it, I'm not saying it's worth it, but if you really need the mod, then try it out

Last seen on 12:14, 19. Jul 2021
Joined May 2019
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Oh thank you for the plugin…
Mon, 07/19/2021 - 12:14

Oh thank you for the plugin but the other thing about the mods I won't do lmao. I just wanted to edit an old of mines to do it better but I can't so I'll just maybe remake it on latest version

Last seen on 22:25, 25. Jul 2021
Joined Dec 2020
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Answering for your 1.12.2…
Wed, 07/21/2021 - 22:36

Answering for your 1.12.2 question - you can make 1.12.2 mods still:

1) by downloading MCreator 2020.2 version
pros

cons

  • unsupported. Like you will never get any update or something
  • it's generally said to use newer Forge to avoid bugs, crashes and all that stuff

2) by downloading plug-in (this one) for 2021.1 version
pros

  • you can have support if anyone starts developing this plugin further (Klemen makes it mostly compatibile, but there are not many features added)
  • you are up-to-date with everything

cons

  • it's counter-intuitive, as many features won't work (as they weren't available in 2020.2), yet are still visible

Generally, I prefer using 2020.2 for now. Because this counter-intuitiveness is really frustrating at times. But if more people starts working on 1.12.2 plugin I mentioned, it will be finally good alternative.
Fun fact: I'm actually learning basics of Java to start developing this plugin a bit further :P I really like 1.12.2 version and it would be cool to make it available fully on newest MCreator.

1.12, unfortunately, has…
Thu, 07/22/2021 - 02:00

1.12, unfortunately, has long been discontinued

Like Toma said, either way, if you want to use this version you are not going to receive support and many features will not work