Attempting to spawn particles on serverside crashes my game

Started by MichaelJackson23 on Tue, 01/11/2022 - 19:22

Topic category: Troubleshooting, bugs, and solutions

Last seen on 16:57, 4. Feb 2022
Joined Dec 2021
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Attempting to spawn particles on serverside crashes my game
Tue, 01/11/2022 - 20:44 (edited)

Whenever I try to load in custom particles serverside, it crashes my game. I have no idea why it does this

Im using MCreator 2021.2 Fabric 1.16.5

Pictures are here:

https://www.dropbox.com/sh/l3vesfyvyp75duy/AACXGBSOaKcI_6j4ctp-_FBMa?dl…

 

The procedure is called "Test"

 

Edited by MichaelJackson23 on Tue, 01/11/2022 - 20:44
Last seen on 00:27, 11. Mar 2022
Joined Jan 2022
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
The Fabric plugin is broken,…
Tue, 01/11/2022 - 19:40

The Fabric plugin is broken, and doesn't support custom particle effects.

You will have to custom-code them and render them.

 Perhaps you can help me with my Mcreator problem:

https://mcreator.net/forum/82934/geckolib-doesnt-work

Last seen on 16:57, 4. Feb 2022
Joined Dec 2021
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
But when I change the block…
Tue, 01/11/2022 - 19:43

But when I change the block to have the custom particles in advanced properties, it works just fine

Last seen on 00:27, 11. Mar 2022
Joined Jan 2022
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
That's because your using…
Tue, 01/11/2022 - 19:58

That's because your using the built-in renderers.