Gradle Error: 1.12.2

Started by NeazKay on Sun, 05/29/2022 - 11:58

Topic category: Help with MCreator software

Last seen on 10:30, 5. Jun 2022
Joined May 2022
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Gradle Error: 1.12.2
Sun, 05/29/2022 - 11:58

I wanted to create a mod on 1.12.2 so i downloaded an older version of MCreator but it's actually not working... Here are the final logs if it could help:

 

 

> Task :downloadAssets FAILED

FAILURE: Build failed with an exception.

* What went wrong:

Execution failed for task ':downloadAssets'.

> Failed to get asset: realms/lang/de_de.json

  Some assets failed to download or validate, try running the task again.

* Try:

Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.

* Get more help at https://help.gradle.org

BUILD FAILED in 3m 33s

5 actionable tasks: 2 executed, 3 up-to-date

BUILD FAILED

Task completed in 214672 milliseconds

Last seen on 10:30, 5. Jun 2022
Joined May 2022
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Please  
Mon, 05/30/2022 - 21:00

Please

 

I'd actually not recommend…
Thu, 06/23/2022 - 08:02

I'd actually not recommend using plugin, but instead relaunching "build source files" tasks (that one with hammer and ticket). As I said previously, plugin does not give you any advantages of new versions, and is really confusing considering you will have 50% of procedure blocks available, but you will not know which ones are usable, and which ones are not.

MCreator 2020.2 has Gradle errors sometimes, so best bet is just relaunching those buttons I mentioned. It can take several launches, since I had similar problem and needed like... 5? 6? relaunches. Good luck ^^