All Blocks are no longer compiling properly

Started by AnonymousFog on Thu, 07/07/2022 - 17:37

Topic category: Troubleshooting, bugs, and solutions

Last seen on 05:09, 9. Jul 2022
Joined Jun 2022
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
All Blocks are no longer compiling properly
Thu, 07/07/2022 - 17:37

So for a while now I have been trying to fix an issue that came up out of nowhere: gradle cache got corrupted somehow.

I tried almost every solution, and inevitably, decided to simply delete the entire .mcreator folder and uninstall the program. I copied my workspace to a separate folder and deleted the MCreatorWorkspaces folder as well.

I reinstalled the program (using the installer that was still on the computer, since I didn't have an internet connection to download it again), and the Gradle Cache corrupt error seems to be gone. That, or it just hasn't gotten the chance to tell me because a new error has shown up.

After re-importing the previous workspace, for some reason, every single block that I had made now doesn't compile properly. It also only shows me 6 build errors (blocks) at a time. I tried just deleting and re-making one of them, and it was still not compiling. I haven't the slightest idea on what "not compiling properly" is even supposed to mean, so I'm at a loss here. I tried looking up a solution but came up empty handed.

I suppose this is supposed to be the part where I put the Console code. I would love to do that if I had any idea how to. When I tried I got an error that said "Body contains longer log or code. Please read our publishing guidelines." Said publishing guidelines did not help.