Can't create a workspace ( hash failed)

Started by Micka678 on Tue, 08/23/2022 - 16:40

Topic category: Troubleshooting, bugs, and solutions

Last seen on 22:10, 14. Sep 2022
Joined May 2015
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Can't create a workspace ( hash failed)
Tue, 08/23/2022 - 16:40

 When i want to create a workspace i get this error.

I tried to reinstall Mcreator multiple times, and i also tried all the solutions from the Gradle setup and Build error wiki.

 

Executing Gradle task: eclipse
Build info: MCreator 2022.2.34517, forge-1.18.2, 64-bit, 16313 MB, Windows 10, JVM 17.0.3, JAVA_HOME: C:\Program Files\Pylo\MCreator\jdk, started on: 2022-08-23-18:27:47
 
> Configure project :
The code of this workspace uses official obfuscation mappings provided by Mojang. These mappings fall under their associated license you should be fully aware of.
(c) 2020 Microsoft Corporation. These mappings are provided "as-is" and you bear the risk of using them. You may copy and use the mappings for development purposes,
but you may not redistribute the mappings complete and unmodified. Microsoft makes no warranties, express or implied, with respect to the mappings provided here.
Use and modification of this document or the source code (in any form) of Minecraft: Java Edition is governed by the Minecraft End User License Agreement available
at https://account.mojang.com/documents/minecraft_eula.
 
> Task :downloadMcpConfig
> Task :extractSrg UP-TO-DATE
> Task :createSrgToMcp UP-TO-DATE
> Task :downloadMCMeta UP-TO-DATE
Copying local object: 0a/0a3f70544d88c6b06f7c40920b432355234a84c2 Asset: minecraft/lang/af_za.json
Copying local object: bb/bba2c6b761b2aa30b6d2ea7dade53ac8c4759ea0 Asset: minecraft/lang/ar_sa.json
Copying local object: 04/04395ba37107692c7600d0264c04207d54743a91 Asset: minecraft/lang/ast_es.json
Copying local object: 42/4227fb1adef545c8a4f4f0710b9b159f87c610ca Asset: minecraft/lang/az_az.json
Copying local object: 81/81bcfdd27f758c3eaf40ec4f72633959d12b1a5a Asset: minecraft/lang/ba_ru.json
Copying local object: 44/44ba5aa2c56b585375177ab9738352d7330eded0 Asset: minecraft/lang/bar.json
Copying local object: 8b/8b0f78f68b23de536bda005db19b08239af7b033 Asset: minecraft/lang/be_by.json
Copying local object: 91/911d2e81a7bff694444c20e630817267b65ff58b Asset: minecraft/lang/bg_bg.json
minecraft/lang/ast_es.json Hash failed.
minecraft/lang/ba_ru.json Hash failed.
Copying local object: 30/3091fe00de69e15789c4c716563b8312eddc0218 Asset: minecraft/lang/br_fr.json
Copying local object: 43/43d05703e1cb5850ef6551196450bbab701b7ba7 Asset: minecraft/lang/ca_es.json
minecraft/lang/af_za.json Hash failed.
minecraft/lang/az_az.json Hash failed.
minecraft/lang/ar_sa.json Hash failed.
Copying local object: 96/968196bdf7be6499743f1a16f36f55b9fe664de5 Asset: minecraft/lang/cs_cz.json
minecraft/lang/bar.json Hash failed.
Copying local object: 57/5773ad3f25b06aa48cd17b2464d38ae72ae82167 Asset: minecraft/lang/da_dk.json
Copying local object: f2/f23ad5caf6e3c702ccdf54058176734db8dc76a7 Asset: minecraft/lang/cy_gb.json
Copying local object: 47/4705813a59aee80d36ca1c7b7c9e0e339e064b57 Asset: minecraft/lang/de_at.json
minecraft/lang/be_by.json Hash failed.
minecraft/lang/bg_bg.json Hash failed.
Copying local object: 56/565a9662c69006a83379958bc5bffc2151bc6d75 Asset: minecraft/lang/de_ch.json
Copying local object: 90/90038bd6a64753f59f67bff023f067af32ab1e99 Asset: minecraft/lang/de_de.json
minecraft/lang/ca_es.json Hash failed.
Copying local object: 8e/8e5af5a59ac1984fd674da34cf50aaa307097cd0 Asset: minecraft/lang/el_gr.json
minecraft/lang/br_fr.json Hash failed.
Copying local object: 6f/6fb6dbeb6fbedf5a308c230874e4c088a74cf9b5 Asset: minecraft/lang/en_au.json
minecraft/lang/de_at.json Hash failed.
Copying local object: 6c/6ce78fcfc98e70c4aeeb5aad1b732520e9499d32 Asset: minecraft/lang/en_ca.json
minecraft/lang/cy_gb.json Hash failed.
minecraft/lang/de_de.json Hash failed.
Copying local object: c4/c456e1b650b72c3eeb2b7a0490179fe64c3687a8 Asset: minecraft/lang/en_nz.json
minecraft/lang/da_dk.json Hash failed.
minecraft/lang/de_ch.json Hash failed.
minecraft/lang/cs_cz.json Hash failed.
minecraft/lang/el_gr.json Hash failed.
minecraft/lang/en_nz.json Hash failed.
minecraft/lang/en_au.json Hash failed.
minecraft/lang/en_ca.json Hash failed.
> Task :downloadAssets FAILED
FAILURE: Build failed with an exception.
* What went wrong:
Execution failed for task ':downloadAssets'.
> Failed to get asset: minecraft/lang/ast_es.json
 Failed to get asset: minecraft/lang/ba_ru.json
 Failed to get asset: minecraft/lang/af_za.json
 Failed to get asset: minecraft/lang/ar_sa.json
 Failed to get asset: minecraft/lang/az_az.json
 Failed to get asset: minecraft/lang/bar.json
 Failed to get asset: minecraft/lang/be_by.json
 Failed to get asset: minecraft/lang/bg_bg.json
 Failed to get asset: minecraft/lang/ca_es.json
 Failed to get asset: minecraft/lang/br_fr.json
 Failed to get asset: minecraft/lang/de_at.json
 Failed to get asset: minecraft/lang/cy_gb.json
 Failed to get asset: minecraft/lang/da_dk.json
 Failed to get asset: minecraft/lang/de_de.json
 Failed to get asset: minecraft/lang/de_ch.json
 Failed to get asset: minecraft/lang/cs_cz.json
 Failed to get asset: minecraft/lang/el_gr.json
 Failed to get asset: minecraft/lang/en_nz.json
 Failed to get asset: minecraft/lang/en_au.json
 Failed to get asset: minecraft/lang/en_ca.json
 Some assets failed to download or validate, try running the task again.
* Try:
> Run with --stacktrace option to get the stack trace.
> Run with --info or --debug option to get more log output.
> Run with --scan to get full insights.
* Get more help at https://help.gradle.org
BUILD FAILED in 2s
5 actionable tasks: 2 executed, 3 up-to-date
 
BUILD FAILED
Task completed in 2 seconds

 

Try clearing Gradle caches…
Tue, 08/23/2022 - 17:18

Try clearing Gradle caches and then make sure to have a stable connection without anything blocking MCreator and try again.

The solution to this problem and many other problems can be found in our knowledge base: https://mcreator.net/support/knowledgebase Please check the knowledge base before opening a new topic on the issue which has a known fix.

Last seen on 22:10, 14. Sep 2022
Joined May 2015
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
I tried clearing caches…
Wed, 08/24/2022 - 17:12

I tried clearing caches multiple times and it still doesn't work.

I am able to create a mod in 1.16.5 thought, for some reason only the 1.18.2 give me this error.

I also tried to create a workspace in 1.16.5 and then updating it i 1.18.2 but it leaves me with the same error.