Procedure, overlay, and mob editor freeze UI on blockly editor on macOS

Published by f_com on Sat, 05/05/2018 - 18:45
Status
Fixed
Type
Product/platform
MCreator/macOS
Priority
Major
Issue description

When I open procedures editor, and I want to place a block of fire instead of another block (X) which is triggered if the block is destroyed by an explosion. So when I press to choose which block will be placed instead of a block X, the whole MCreator just freezes.

EDIT BY DEVELOPERS:

This bug was fixed. To try if it works, download mcreator.jar from the link provided below and replace mcreator.jar from your installation with the downloaded one. After you do this, run MCreator and try to use the procedure block selection feature. A similar bug was found in overlay and mob creator. Due to many changes required to fix this, we are asking users of any platform to test MCreator with this fixed jar file to see if we broke anything else by fixing this.

Download link to fixed mcreator.jar 1.7.9: http://www.mediafire.com/file/7steqcjrfzsm00a/mcreator.jar

Please note that this mcreator.jar is covered by our TOS as any other MCreator file.

Attachment Size
File contains full error log and a workplace318.11 KB 318.11 KB

Issue comments

So this only happens when you click on the gray box when selecting the block in procedure maker?

Try to run MCreator from the terminal and provide error log from actual MCreator. The log you provided does not contain any information that could help me locate the cause. Thanks!

I have uploaded a new version with a potential fix at 6.5 9:10 CEST. Please re-download and re-install MCreator and report back if this issue is still present.

I suspected bad thread management between UI and block editor. I hope this fixed the bug you reported.

Please report back!

Sorry for a late response, I had to leave urgently...
I tried it and the issue is still present( I tried to launch it via terminal but it gave no logs. The mcreator freezes and it doesn't respond so i can't collect error logs(

Could you please run command java -version in the terminal and report back with the output you get? Thanks!

This is the output:
 

java -versioniMac-Farrukh:~ farrukh$ java -version

java version "1.8.0_171"

Java(TM) SE Runtime Environment (build 1.8.0_171-b11)

Java HotSpot(TM) 64-Bit Server VM (build 25.171-b11, mixed mode)

This is a very strange issue. I will look further and reply back if I manage to find the cause of this bug.

To other macOS users, if anyone else has this issue, please provide as much information as possible so we can resolve this issue.

I don't think so. I will try to understand the error log you provided and try to spot the error. But this is definitely a Java bug, the best we can do is to find a workaround.

If you have time, you can try to update to Java 8u172. Right now you have Java 8u171. This might help, but I am not sure. Make sure to keep it on Java 8 though as version 9 is not supported at all.

Is there any user with macOS that would be ready to help me fix this bug. I anyone volunteers, I can reach to him via mail and send him some test versions of MCreator with potential bugfix for this.

I would like to help you fix the problem! To be honest, I dont understand a single word of java but if I just have to test some mcreator versions, this should be feasable. Can you see my email or do I have to send it?

FalsetuneD, I will send you the potentially fixed version to the email you used to create the account after I manage to find potential causes of this crash.

There is no fix yet, I am working on finding a potential fix that will then need to be tested by macOS users as I don't have a Mac to test on it.

I have sent another attempt at fixing this bug to all of you who said that would like to test it. Please report back if the fix worked. Thanks!

It´s still freezing when I click on the block selector. To be honest I don´t know how to find the crash log

Thank you for the video! I have sent you another attempt at fixing it. I managed to set the environment on Windows to reflect macOS Java and replicate the bug. I think the version I sent you now will fix the bug. Please report back if it works now!

I have sent you the V4 fix on the email. Please report if it worked this time. It turns out this is a complex threading issue and many elements of MCreator had to be adapted to make it work. Please test it and report if it worked.

Fix is not implemented yet. Is this fix going to be posted soon, or is it something that will be released for the next version?

I was so excited to start making a mod, and then found out that I could not. I am excited to download it and start again.

When I downloaded the file in the link & tried to open it, it would launch at all. It said: "MCreator... Could not be launched."



Donate to MCreator

By donating to developers you can speed up development, as with more resources, we can dedicate more time to MCreator. It is a free project made by developers working on it in their free time.