Arduino Toolkit problems

Published by Ale Lav on Thu, 07/26/2018 - 13:45
Status
Can not reproduce
Product/platform
MCreator/Windows
Priority
Normal
Issue description

I have had the Arduino Toolkit in my mind for a while now, and 2 days ago, I decided to give it a try (it looked really exciting to me). So I set to work, doing everything step by step, with an Arduino nano, and MCreator 1.7.9. The video did not work, so I went to the MCreator post (https://mcreator.net/wiki/mcreator-arduino), followed it step by step, with no solutions being brought up. I started to see if others had had these issues, and found a few solutions. I turned off my Firewall, tested the Arduino's serial capability through the IDE's serial monitor, etc. I tried my own solution to run the .jar file on administrator mode, to no avail either. I even reverted my MCreator version to the version on the video to see if that would help me at all: it didn't.

I'm not sure what else there is I can do to solve this, so I have come to you guys. The workspace I last used to test this is exported below. I would highly appreciate some help!

Issue comments

So what exactly is not working? You said the video did not work, but I can't quite catch what you meant with this?

Is MCreator to Arduino interface not receiving messages, are they not sent to the serial port?

Whoops, apologies for the miscommunication.

I meant that neither the steps in the video nor the steps in the post work, after I have done them in full detail with my Arduino nano.

I open the Java interface with cmd (my computer doesn't do double-click jar file opening) and it does open, and the "Connect" button grays out when I choose the right serial port, which I assume means it worked (I checked if the program was truly communicating with the Arduino by going to the IDE and trying to open the serial monitor: the serial port stated it was "busy", meaning something else was using it). Using MCreator 1.7.9, I made 2 procedures, one that sent the string "red" on any external call, and the other "blue". I set the "red" procedure to the block's "Redstone on" event, and the "blue" procedure to the block's "Redstone off" event. I opened the test client environment, placed the block, hooked some redstone to it, and added a lever to the chain. I pull the lever, and nothing happens, the Java program's send-receive indicators do not blink, and my Arduino does nothing in response.

I have done some debugging on this, to see if the block's events are actually working; I played a sound when the block was placed, made it print "ON" on "Redstone on" and print "OFF" on "Redstone off". Which did work fine. You can see it in the console log of the workspace I exported.

I don't know what else to try, can I have some ideas?

So the UDP > COM icon is not blinking? This means that data is not transmitted from the Minecraft to the MCreator to Arduino connector.

MCreator uses UDP port 5050 to send data to the connector, so make sure that this port is not used by any other software or blocked by any firewall or antivirus.

You might want to test to send packets to the connector from a test utility instead of Minecraft. You need to send the data you want to send to the connector to the port 5050 to the address 127.0.0.1 using UDP protocol. You could use a tool like this one to test this: https://packetsender.com/

Apologies for this delay, I am not currently at my desk. I willl return in a day or 2. Thanks for understanding ;)

Alright, I have returned and run this test. I sent some packets to 127.0.0.1:5050 after connecting my arduino to the java interface, and I found that sending packets through packet sender did not prompt a reaction from the application. I retried the process with my antivirus' Firewall turned off, but nothing changed. What does this mean?

You might need to turn off Windows firewall in such case too. Or add java.exe that is used to run the MCreator to Arduino connector to the exceptions of your AV and FW. I am afraid that at this point I can help you much anymore, it seems that the issue is somewhere in your computer blocking the connections.

Wait! I just found out I was running the java file with javaw.exe instead of java.exe. Since I can't open .jar-s with double clicking, I wrote a batch script that could do it, and I found out I was using javaw.exe. I ran it with java.exe. and this occured:

Here is a picture of the command prompt after these changes

What does "Closed" mean? You don't want to help me anymore?

I thought you only had issues with the network, which I could not help any further. Regarding this new issue, try moving MCreator to Arduino connector to a new folder and try running it from there.

I have downloaded a fresh zip, and ran the same command, except I made a dedicated folder and it worked for me.

If this does not work, I am afraid I have no more ideas. If I have some spare time, I might write a more robust version of this connector or if I get some kind of donation by summer camp or school which is interested in using MCreator for Arduino for their lessons. When/if I do this, I might integrate send and receive data blocks in procedure editor too.

I tried this, with different outcome. I freshly downloaded the .zip file and ran a Powershell window, ran this command, and found that the exact same "Version mismatch" appeared. I ignore the mismatch, and choose the serial port, and the *instant* I click "Connect", a gigantic java.net.BindException is thrown, reading:

Huge BindException

This has happened to me when I first unsuccessfully ran the program. It does not close the UDP port properly in such case. I had to restart my computer and afterwards, it worked the next time I launched the app. Please report if this worked.

I restarted at your request, and did this as soon as I could when I booted up. And the (seemingly) exact same exception was thrown.

We have completed the development of our new system for connection of Minecraft to Arduino and Raspberry Pi devices. If you are interested, you can find more info on this page: https://mcreator.net/link

The new project is opensource, has a lot of examples, video tutorials and is documented to help you get started.

Recent release article: https://mcreator.net/news/46828/minecraft-link-connect-your-mods-real-w…



Donate to MCreator

By donating to developers you can speed up development, as with more resources, we can dedicate more time to MCreator. It is a free project made by developers working on it in their free time.