Crash with Custom Sound and Custom Music

Published by Goldorion on Thu, 08/02/2018 - 16:00
Status
Works as designed
Type
Product/platform
Not applicable
Priority
Normal
Issue description

Hello,

I would just like to tell you that I found a bug. I wanted to put music and custom sounds that I had made myself. So I took my music files and sounds, I put them in .ogg, for the format, and I imported them in my Worskpace on MCreator.

So I started my game because I wanted to see if it worked, and as soon as I wanted to play one of my audio files, I have my game that crashed.

I will tell you again what I did.

1. Put my files I created on Mcreator. (I put .ogg files.)
2. I import all the other files.
3. I start the game
4. I execute the command / playsound testenvironmentmod: thenameofmycustomsoundand / sound.
5. Press the Enter key.
6. I have the game that crash.

I give you the link of my Workspace.

http://www.mediafire.com/file/3jdyl6v7gme3cvn/0.7.0+Final.mcr

Issue comments

That's the mistake. I gave you everything I saw in the console, since I made Enter

 

 

[15:32:14] [Server thread/INFO]: [Player181: Played sound 'testenvironmentmod:hostile.lastboss' to Player181]
[15:32:14] [main/INFO]: [CHAT] Played sound 'testenvironmentmod:hostile.lastboss' to Player181
[15:32:14] [Thread-5/ERROR]: Error in class 'CodecJOrbis'
[15:32:14] [Thread-5/ERROR]: Ogg header not recognized in method 'readHeader'.
[15:32:14] [Thread-5/ERROR]: Error in class 'CodecJOrbis'
[15:32:14] [Thread-5/ERROR]: Error reading the header
:runClient FAILED
FAILURE: Build failed with an exception.
* What went wrong:
Execution failed for task ':runClient'.
> Process 'command 'C:\Pylo\MCreator179\jdk\bin\java.exe'' finished with non-zero exit value -805306369
* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.
BUILD FAILED
Total time: 8 mins 52.787 secs
C:\Pylo\MCreator179\forge>
Task completed with return code 0 in 533455 milliseconds

I have already played the audio file, and I can play it perfectly. I have no problem with audio file corruption.

I have checked the ogg file in the workspace you provided. You have used two really long ogg files. You are supposed to use only short sound effects, not whole songs as the ogg player in Minecraft is not optimized for such files, the only support for them is as ambient or recording sounds.



Donate to MCreator

By donating to developers you can speed up development, as with more resources, we can dedicate more time to MCreator. It is a free project made by developers working on it in their free time.