Andesite/Stone Bug

Published by KreatorB on Tue, 10/02/2018 - 18:21
Status
Can not reproduce
Type
Product/platform
Not applicable
Priority
Normal
Issue description

I am in the middle of creating a block using andesite with a piece of white dye in the center and when I create the block output and recipe all works fine. when I go into my world and create that block in a crafting table it creates the stone version of the same recipe. 

I checked to make sure that my recipe was not messed up by me, all is in the right place, right setup but yet I get a wrong out put.

Note, that I do have a recipe that is setup the same way with stone and white dye and it worked fine before, this seems that the andesite calling up stone and not andesite.
I also check the other recipes with andesite in creative and they all worked. It is only the orginal andesite that does not work. It is as if the  Andesite block is really encoded as Stone.
Please HELP!

KB

Issue comments

I was not able to find your recipe, but I created a recipe myself and andesite was properly used in both input and output slots, even with multiple recipes as you did. I was not able to replicate this bug, unfortunately.

It could be that you accidentally defined the same recipe twice, once with stone and once with andesite.

OKay, Here is what is it.

andesite andesite  andesite 

andesite  dyecolor andesite     =    dyed andesite 

andesite  andesite  andesite 

I have same recipe for stone for all the dyes!

When you create these using andesite  they give you the stone version.

I will output the mod and test it and snapshot the error

 

OKAY seems to be working now. Maybe it was bug that once recompiled left. CLOSE ticket SORRY 

 

 



Donate to MCreator

By donating to developers you can speed up development, as with more resources, we can dedicate more time to MCreator. It is a free project made by developers working on it in their free time.