Start block randomly missing

Submitted by fishcute on Sat, 05/11/2019 - 00:39
Upvotes: 2
Issue description

So sometimes when I leave a procedure block, an error appears then I re-enter the procedure block and EVERYTHING is gone, even the start block. It happens whenever I put in a big command executing such as giving players a book. Its really annoying because I lost all of my progress. Fix this before I give up and move onto 1.8.2. I really hope you fix these bugs before you release 1.8.4

Attachment Size
Screenshot (854).png493 KB 493 KB

Issue comments

Submitted by Klemen on Sat, 05/11/2019 - 10:12

Could you give me an example of a command you enter in a execute command block in order for this issue to happen? Thanks!

Submitted by fishcute on Sat, 05/11/2019 - 11:15

Ok sure

Just an example:

/give @p written_book 1 0 {pages:["[\"\",{\"text\":\"T\",\"color\":\"dark_red\"},{\"text\":\"h\",\"color\":\"dark_blue\"},{\"text\":\"is is a book\\nYes\",\"color\":\"dark_red\"},{\"text\":\" it is am\",\"color\":\"dark_aqua\"},{\"text\":\"azing\",\"color\":\"dark_red\"},{\"text\":\"\\n\",\"color\":\"reset\"},{\"text\":\"A\",\"color\":\"green\"},{\"text\":\" BOOK\\nIt i\",\"color\":\"dark_purple\"},{\"text\":\"s a book\",\"color\":\"green\"},{\"text\":\"\\n\\nI am a book\\nBooks are books\\nwhich mean books are books are books\",\"color\":\"reset\"}]","{\"text\":\"Page ?+2\\nHi\\nExample\\nExample\\nExample\"}"],title:"Super book of bookness",author:Book,display:{Lore:["Description description Description description Description description Description description Description description Description description"]}}

Submitted by Klemen on Sun, 05/12/2019 - 10:53

I have tried your command. I made a new procedure and pasted your example in execute command block, saved it and opened it again and it still worked. I there any option to attach a workspace that has a procedure that does not work in it and tell me which procedure to check?

Submitted by Klemen on Mon, 05/13/2019 - 15:16

My suspect is that some string is not properly escaped and causes this, but it could be your case too. I need an example of a procedure that does not open so I can properly investigate, though.

Submitted by fishcute on Tue, 05/14/2019 - 10:44

It only happens rarely, but frequent enough to make me make this help thingy. It has happened to me twice. It starts by saying something went wrong and the procedure goes red then I re-enter and it is gone

Submitted by fishcute on Tue, 05/14/2019 - 10:47

Perfect example of a unsuspecting pray of this bug

Perfect example of a unsuspecting pray of this bug

Submitted by Klemen on Tue, 05/14/2019 - 18:43

fishcute, it seems that this is not actually caused by the content of the procedure but by some other event, as BadKaiPanda suggested too. Could you provide a workspace that contains corrupted procedures so I can investigate how they got corrupted? Thanks!

Submitted by fishcute on Tue, 05/14/2019 - 19:25

Like an empty one that got corrupted?

Submitted by Klemen on Tue, 05/14/2019 - 19:28

One that got corrupted.

Submitted by fishcute on Tue, 05/14/2019 - 19:33

It says I cannot download the procedure

Submitted by Klemen on Tue, 05/14/2019 - 19:57

Thank you, I will check why this is happening and do my best to fix this bug.