3D armor not working right

Published by NavaRayUK on Mon, 07/01/2019 - 13:16
Upvotes: 4
Issue description

No matter what I do for textures for the 3D model it does let you set a texture for it, also when using the 3D armor it's still makes you select the 2D armor and this 
section is lost, no steps to show or explain one bit.

If you have this fully working on your test can you post a quick tutorial or release the mod element to see if we can see why no other user is able to get it to work.

 

I had to change this part to get part of the texture to load but still not working right 
 


			@Override
			public String getArmorTexture(ItemStack stack, Entity entity, EntityEquipmentSlot slot, String type) {
				return "morecubedemo:textures/items/lid.png";
			}


This is very wrong as front and right side of the model/face is covered

Attachment Size
lid.png222 bytes 222 bytes
unknown_1.png115.07 KB 115.07 KB
armor model example.zip15.52 KB 15.52 KB

Issue comments

I think I have found a bug with armor textures. I will try to fix it and release another patch update. I will share example workspace after the patch too.

PATCH UPDATE 1. 7. 2019, 16:40 CET

There were some bugs found in MCreator 1.9.0 so we decided to release a patch update. If you are having one of the following bugs and downloaded MCreator before the time of the patch, consider reinstalling version 1.9.0:

  • [#50791] Custom armor model textures were not properly applied
  • Some other minor bugfixes and additions

To apply the patch (fix these bugs), uninstall MCreator 1.9.0, download it again and install it again.

I have made an example and attached it: https://mcreator.net/sites/default/files/attachments/armor%20model%20ex…

Here you have a blockbench project, exported java model and its texture. You have ZIP file with MCreator workspace in it too (excuse random names of the mod elements and textures, I was in hurry :D). Import the workspace in MCreator to see examples.

General notes are:

  • Use custom texture for custom models, From armor texture requires knowledge of how are textures mapped relative to biped model and generally, you don't want this. If you use specific texture (from category Other) for each part, you just need to use the same texture mappings as in the modeler.
  • Armor models need to have the same pivot point as the pivot point of the player parts (for example head and helmet)

This example will only work in the patched version of MCreator.

Submitted by NavaRayUK on Mon, 07/01/2019 - 15:11

If you can please view the discord, there is a render bug still and the armors model is not rotated on armor stands 

 

Submitted by NavaRayUK on Mon, 07/01/2019 - 15:58

ya it seems if we may it lower then the 1 cube so half or quorter and even recreate the textures for it, it messes up, not sure why, but I seen 3d armor this small before not sure why's creating it.

With the default renderer, it seems it is not possible to make layers that thin. You can check the code of the armor to see how I apply a custom model to the second biped render layer.

I will do some googling today to look for ideas.

Submitted by jman200361 on Sat, 08/10/2019 - 19:08

how do i fix diaplacement in the model

Like displacement on the player? If this is the case, try moving the offset values of the armor part in the direction to fix this issue and reimport model. It might require some trial and error, depending on the modeler you use.

Submitted by Crayeights on Sun, 09/01/2019 - 15:54

yeah I put the arms parts under the the torso in block bench and then texture will show but still no motion to the shoulders.



Donate to MCreator

By donating to developers you can speed up development, as with more resources, we can dedicate more time to MCreator. It is a free project made by developers working on it in their free time.