Switch Dimension for Entity still doesn't work in 1.9.0

Upvotes: 2
Issue description

I am using Mcreator 1.9.0, and I am using the Switch Dimension for entity procedure block. However, I stay in the same dimension, without anything changing.

Log (one part is cut due to size limits, the cut part was just the same thing repeated over and over anyway): https://pastebin.com/CqEjQK8M


How to reproduce: (it's pretty long)

  • Take the 'Galaxy Console' Block, the Ship Hull (basic), the prismatic warp drive (first one in tab 'Trailblazer ship parts') and solar panel (also the first one you come across in that tab)
  • Right click on the Galaxy Console, and choose the button 'assemble ship'. Put the items I mentioned above in their respective slots (Hull, warp drive and power source)
  • Click Assemble
  • Click Assemble on the warning that comes up
  • Leave the GUI with Esc.
  • Right click on the console again
  • Click 'Galaxy Map'
  • Click 'Leave atmosphere'

Nothing should happen except the ship door closes.

What is supposed to happen is your dimension is switched and then you are inside the ship (with closed door) in the new dimension.

Issue comments

If possible, attach the workspace, yes. And tell me which mod elements to check (dimension, procedure and element that triggers procedure elements).

And before you do this, do you have any structures set to spawn in dimension and how often are they set to spawn as this is most likely causing the dimension to not load?

Notices like these show that Minecraft can not keep up due to something doing a lot of work:

16:03.15 [Server thread/WARN] [minecraft/MinecraftServer]: Can't keep up! Did the system time change, or is the server overloaded? Running 4602ms behind, skipping 92 tick(s) 

It could be some procedure being triggered a lot too. You are not teleported because teleport is initiated, but then there is that much CPU/RAM load that Minecraft can't keep up and you are not teleported.

Ok, I could see this straight away, if you wrote these instructions in the first place I would know the cause :D

The issue is that you are requesting a dimension switch from a GUI button. There is an issue associated with GUI button events: https://mcreator.net/tracker/issue/50752

I have imported your workspace in 1.9.1 and the teleportation worked.



Donate to MCreator

By donating to developers you can speed up development, as with more resources, we can dedicate more time to MCreator. It is a free project made by developers working on it in their free time.