Compiling error after editing creative tab layout

Status
Can not reproduce
Type
Product/platform
MCreator/Windows
Priority
Normal
Issue description

I started to get random compiling errors last night on the latest patch for 2020.2 I am not sure what the build is for that patch but it first started when I changed the order which the creative tabs where organised using the tool on the top tool bar of the workspace tab.

I did end up fixing that issue by uninstalling and reinstalling MCreator and it worked for a while but then ran into another compiling error after updating the logo image.

The mod works perfectly when its not screaming that specific elements have issues when they don't have anything wrong with them. I have attached the workspace and console log in the zip file. From what I can tell other people may be having the same issue lately.

Attachment Size
Console log and workspace.2.72 MB 2.72 MB

Issue comments

I've heard reports of this happening but was not able to reproduce yet. It worked when I imported your workspace, so probably Regenerate code and build button will solve this.

I tried switching the tab order again but it did not happen. Does this happen each time you switch tabs or is there a specific order of actions for this to happen?

Far as I know its no specific order, its random by the looks of it, both times I was working on a project for over an hour so it may be time related maybe. Regenerating the code did work.

Although I forgot to test if the problem was still happening when I started the workspace up again, I will do so next time it to see if its just something in the background of the program like the java app that stays up, I could end that task technically to see if it fixes the issue when it happens correct?

Would it be fine to reply to this post when I find more information?

I ran into the issue again, regenerating the code did not work, the steps below fixed the issue.

  1. Regenerated the code (did not work)
  2. Close the program
  3. Start the program back up.
  4. Regenerate the code (it fixed the issue)

I don't think its the java background process if a simple restart fixes the issue then so no point in me testing that.

One thing that came to mind was its I noticed that it had to do with a period in the code so could it not have something to do with the Blockbench models maybe?

My Blockbench settings are using it for 1.12 however in 2020.1 it worked fine with this setup I know that you can change it to 1.14 so I will try that to see if there is any difference in fixing the compiling errors and get back to you when I have some more information. It may be worth looking to see if other people are having the issue with mods with entities in them it could just be a Blockbench setting at this point.

I ran into the issue again, regenerating the code did not work, the steps below fixed the issue

The error log was the same as the last time?



Donate to MCreator

By donating to developers you can speed up development, as with more resources, we can dedicate more time to MCreator. It is a free project made by developers working on it in their free time.