UBUNTU DOESNT WANT TO WORK

Status
Invalid
Type
Product/platform
MCreator/Linux
Priority
Normal
Issue description

I cant install mcreator on ubuntu. The terminal says it cant read file libXtst.so.6 and I cant find anything about it.

Can someone help?

 

Issue comments

Can someone help?

With that much info, no. You did not include a full log nor provide any system details.

hope ths provides more info

it says exactly: 

:~/Downloads/MCreator20195.jar$ ./mcreator.sh
2020-04-14-12:46:15 [main/INFO] [Launcher] Starting MCreator 2019.5.51710 - 201900551710
2020-04-14-12:46:15 [main/INFO] [Launcher] Java version: 1.8.0_222, specification: 1.8, VM name: OpenJDK Server VM
2020-04-14-12:46:15 [main/INFO] [Launcher] Current JAVA_HOME for running instance: /home/robert/Downloads/MCreator20195.jar/jdk/jre
2020-04-14-12:46:15 [main/ERROR] [Exception] Uncaught exception in main
java.lang.UnsatisfiedLinkError: /home/robert/Downloads/MCreator20195.jar/jdk/jre/lib/i386/libawt_xawt.so: libXtst.so.6: cannot open shared object file: No such file or directory
    at java.lang.ClassLoader$NativeLibrary.load(Native Method) ~[?:1.8.0_222]
    at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1941) ~[?:1.8.0_222]
    at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1824) ~[?:1.8.0_222]
    at java.lang.Runtime.load0(Runtime.java:809) ~[?:1.8.0_222]
    at java.lang.System.load(System.java:1086) ~[?:1.8.0_222]
    at java.lang.ClassLoader$NativeLibrary.load(Native Method) ~[?:1.8.0_222]
    at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1941) ~[?:1.8.0_222]
    at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1845) ~[?:1.8.0_222]
    at java.lang.Runtime.loadLibrary0(Runtime.java:870) ~[?:1.8.0_222]
    at java.lang.System.loadLibrary(System.java:1122) ~[?:1.8.0_222]
    at java.awt.Toolkit$3.run(Toolkit.java:1636) ~[?:1.8.0_222]
    at java.awt.Toolkit$3.run(Toolkit.java:1634) ~[?:1.8.0_222]
    at java.security.AccessController.doPrivileged(Native Method) ~[?:1.8.0_222]
    at java.awt.Toolkit.loadLibraries(Toolkit.java:1633) ~[?:1.8.0_222]
    at java.awt.Toolkit.<clinit>(Toolkit.java:1670) ~[?:1.8.0_222]
    at java.awt.Color.<clinit>(Color.java:275) ~[?:1.8.0_222]
    at javax.swing.plaf.metal.MetalTheme.<clinit>(MetalTheme.java:76) ~[?:1.8.0_222]
    at net.mcreator.preferences.PreferencesData$UISettings.<init>(SourceFile:74) ~[mcreator.jar:?]
    at net.mcreator.preferences.PreferencesData.<init>(SourceFile:18) ~[mcreator.jar:?]
    at net.mcreator.preferences.c.<clinit>(SourceFile:16) ~[mcreator.jar:?]
    at net.mcreator.Launcher.main(SourceFile:81) ~[mcreator.jar:?]
 

 

Check if files /home/robert/Downloads/MCreator20195.jar/jdk/jre/lib/i386/libawt_xawt.so exists. If it does not, try reinstalling MCreator.

Is your platform 32- or 64-bit?

If you do not have at least 4 GB RAM, you will not be able to make Forge mods, but can still make data packs and addons, unfortunately.

Please help me, I want unistall mcreator in/on ubuntu 18.04.



Donate to MCreator

By donating to developers you can speed up development, as with more resources, we can dedicate more time to MCreator. It is a free project made by developers working on it in their free time.