Choose generators doesn't work

Published by Goldorion on Sat, 04/18/2020 - 16:20
Upvotes: 1
Issue description

Hi,
I tried to upgrade my workspace to Minecraft 1.15.2, but I didn't have the menu with the generators. So, I restart MCreator and it didn't work. I tried to create a new workspace to see if it was only desactivate, but no. I delete the gradle file into the .mcreator folder, but we can't create a new workspace and change the generator type. i tried to see on the tracker if someone had the same problem, but I didn't fine someone reporting this problem, so I imagine there is only something wrong in my workspace or something I did wrong.

I will give you my workspace as soon as gradle files are finished to be downloaded.

Attachment Size
Video to change the generator4.44 MB 4.44 MB
Video to create a new workspace288.15 KB 288.15 KB
My resource pack generator plugin55.76 KB 55.76 KB

Issue comments

i find the cause. I had still plugins of 2020.2. My bad, but you should may be put a message.

2020.2 plugins should not even load in 2020.3 so this is a bug on my side, but would still need a plugin to test why this is happening :)

I give you my resource pack generator, and it surely doesn't work because I wrote resourcepack for the flavor.

It indeed crashes, I will fix this. A tip would be to specify maxversion in a plugin too, just to be sure.

I don't think I can handle all the cases of wrong plugins, but I will do my best to cover it as much as possible.

There will be a log in the terminal with the cause and warning if a plugin will fail to load for the devs too.



Donate to MCreator

By donating to developers you can speed up development, as with more resources, we can dedicate more time to MCreator. It is a free project made by developers working on it in their free time.