Can't craft armor

Status
Resolved
Type
Product/platform
Not applicable
Priority
Normal
Issue description

I have this problem since the full release of MCreator 2020.4

(Version 1.14.4 FG)

 

In the last versions of MCreator I was able to craft all of my armor pieces (6 armors)
In the last few days I changed a lot of IDs of items and blocks. At first I thought this could be the problem until I tested other recipes of items and blocks that got a new ID. These worked. I also tested it with the same materials that the armor pieces needed. I was also able to craft these (for example a sword with the same material).
I also recreated the recipes for the armor pieces. It still did not work. I wasn't able to craft any armor piece of all 6 armors. I also checked for procedures that might include the armor. But also armor pieces wasn't able to be crafted that did not had any procedure linked to it.

I'm only able to take it out of the creative inventory and to wear it (stats, etc. work). Only the crafting does not work for some weird reason.

This also might be linked to my achievements. I have a few achievemts which includes 2 of these armors. I can't unlock this achievement (which I changed now (for testing) to just have the helmet in inventory) and all other achievemts after this specific one (worked before full release of 2020.4). Before the player had to craft any piece of that armor

Issue comments

UPDATE: We have released a patch update to fix two bugs found in 2020.4:

2020.4.32115:

  • [Bugfix #64811] Help tips were not loaded in UTF-8 encoding
  • [Bugfix #64826] Custom armor broke recipes and advancements referencing it

To install the patch, re-download 2020.4 and install it again.



Donate to MCreator

By donating to developers you can speed up development, as with more resources, we can dedicate more time to MCreator. It is a free project made by developers working on it in their free time.