AI Base changes name of boss

Started by TortousGER on Sun, 01/22/2017 - 20:01

Topic category: Help with MCreator modding

Last seen on 18:52, 24. Aug 2018
Joined Dec 2016
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
AI Base changes name of boss
Sun, 01/22/2017 - 20:02 (edited)

Hey guys!

So I have a problem: I created a boss (it isn't a biped model, it is a custom model made with techne), and it won't attack even I add the AI Task "act agressively against EntityPlayer". So I thought it is in cause of the model but when I selected the zombie AI base the boss bar changes the name to "Zombie". Even the drop is rotten flesh. I don't want to use a biped model, so I would appreciate it if you could give me a solution without changing the model.

P.S.: I just make mods with MCreator, so I have no experience with Java or Codes, etc... So, if you have a solution where I must change something in the code, please explain it for dummys ;)

Edited by TortousGER on Sun, 01/22/2017 - 20:02
Last seen on 13:38, 21. Aug 2018
Joined Oct 2016
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
I had this problem too (Made
Mon, 01/23/2017 - 00:21

I had this problem too (Made a Story Mode mod. Had a White Pumpkin mob with Zombie model)

Last seen on 22:17, 29. May 2018
Joined Oct 2016
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
RE:I had this problem too (Made
Mon, 01/23/2017 - 02:46

Use attack on collide so they will be able to hit you and then they will start moving to the target

 

Last seen on 18:52, 24. Aug 2018
Joined Dec 2016
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
RE:RE:I had this problem too (Made
Mon, 01/23/2017 - 15:11

@#2 That was a good idea, but it didn't worked... I guess I need to change the model into a biped -.-

Last seen on 08:29, 18. Sep 2019
Joined Dec 2013
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
It depends on the MCreator
Mon, 01/23/2017 - 19:56

It depends on the MCreator version you are using. The latest MCreator (1.7.1) and (1.7.2) Should work fine with choosing any model. When you make the mob make sure to choose Agressive and "is a Mob". Set the "Actaggresivelyaggainst" to 10 priority. I know for a fact this works as I have tested at least 60 of my mobs in my new mod im working on, all have some sort of custom model except a few.

Last seen on 18:52, 24. Aug 2018
Joined Dec 2016
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
RE:It depends on the MCreator
Tue, 01/24/2017 - 14:14

@#3 Okay, I will try that. Can I import mcr files from 1.7.1 into the MCreator 1.7.2? And will this be fixed in the Minecraft 1.11.2 MCreator Update? Because I really want to do this in the newest version of MC.

Last seen on 18:52, 24. Aug 2018
Joined Dec 2016
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
RE:It depends on the MCreator
Wed, 01/25/2017 - 18:53

@#3 I just tried it, and I can't import my mcr files from 1.7.1 into 1.7.2... Thanks, but I need to wait until 1.7.3, I guess.

Last seen on 13:42, 12. May 2018
Joined Jan 2016
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
From what you wrote, i don't…
Wed, 04/04/2018 - 14:26

From what you wrote, i don't know if you tried to put both "Act Aggresivly Against" with a 10 priority and "Attack On Collide" with a 10 priority at the same time. It always worked for me, no matter what version, tho i'm currently using 1.7.4 for testing a WIP mod