All Features In Plains With 2023.3

Started by Jofini on

Topic category: Troubleshooting, bugs, and solutions

Last seen on 20:49, 25. Feb 2024
Joined Aug 2023
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • MCreator plugins:
  • Comments:
All Features In Plains With 2023.3

Currently with the new update, all modded features still generate in the plains biome which includes mobs, plants, features, and structures. This is not an issue with 1.20 because the issue persists in 1.19. Any solutions or ideas would be much appreciated!

Last seen on 23:34, 25. Feb 2024
Joined May 2022
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • MCreator plugins:
  • Comments:
I have the same problem, and…
Fri, 09/08/2023 - 23:52

I have the same problem, and am considering filing a bug report on Github. Weirdly I'm not sure why this is an issue, as everything appears to be working normally in src.

Last seen on 23:34, 25. Feb 2024
Joined May 2022
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • MCreator plugins:
  • Comments:
...In the meantime I've…
Sat, 09/09/2023 - 19:00

...In the meantime I've found it is still possible to restrict things to specific biomes by manually writing an additional generation condition for it. However, you can't simply exclude plains, as things then seem to still generate on the biome borders of plains. As long as you don't have, just purely for example, 200+ small distinct structures with very specific biome requirements, it shouldn't be too difficult to fix. 

Last seen on 12:49, 30. Sep 2023
Joined Dec 2016
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • MCreator plugins:
  • Comments:
I had the same issue.  The…
Wed, 09/27/2023 - 21:30

I had the same issue.  The biome_modifier.json file in the specific block or structure is adding plains as an option.  Here is an example

{
"type": "forge:add_features",
"biomes": [
"bamboo_jungle",
"sparse_jungle",
"plains",
"jungle"
],
"features": "terracraft:mud",
"step": "underground_ores"
}

Removing the line with plains in it resolves the issue but you will have to lock the code afterwards.  Curiously, if your block or structure only generates in custom biomes, this isn't an issue.

Last seen on 23:34, 25. Feb 2024
Joined May 2022
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • MCreator plugins:
  • Comments:
I did check the json files,…
Wed, 09/27/2023 - 23:06

I did check the json files, and this was part of the  issue- it turned out to be a problem refactoring the workspace. (Some elements had previously been told to generate in biomes that didn't exist in the latest version- modified jungle, birch forest hills, etc.) For most of the elements this could be fixed from Mccreator, but some did require messing with the files themselves.