My mod crashes

Started by Gunter69 on Mon, 04/04/2016 - 08:30

Topic category: Help with modding (Java Edition)

Last seen on 08:00, 12. Sep 2017
Joined Apr 2016
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
My mod crashes
Mon, 04/04/2016 - 08:30

I just made a mod for 1.7.10, I exported it and ran it in Minecraft with Forge, but it crashes when I open a world. Strangely, the mod works correctly when loaded in Tekkit Legends 1.7.10. Here is the crash report?

---- Minecraft Crash Report ----
// On the bright side, I bought you a teddy bear!

Time: 4/04/16 10:30
Description: Unexpected error

java.lang.IndexOutOfBoundsException
    at java.nio.Buffer.checkIndex(Unknown Source)
    at java.nio.DirectIntBufferU.get(Unknown Source)
    at net.minecraft.client.renderer.RenderGlobal.func_72712_a(RenderGlobal.java:350)
    at net.minecraft.client.renderer.RenderGlobal.func_72732_a(RenderGlobal.java:294)
    at net.minecraft.client.Minecraft.func_71353_a(Minecraft.java:2216)
    at net.minecraft.client.Minecraft.func_71403_a(Minecraft.java:2146)
    at net.minecraft.client.network.NetHandlerPlayClient.func_147282_a(NetHandlerPlayClient.java:240)
    at net.minecraft.network.play.server.S01PacketJoinGame.func_148833_a(SourceFile:70)
    at net.minecraft.network.play.server.S01PacketJoinGame.func_148833_a(SourceFile:13)
    at net.minecraft.network.NetworkManager.func_74428_b(NetworkManager.java:212)
    at net.minecraft.client.Minecraft.func_71407_l(Minecraft.java:2061)
    at net.minecraft.client.Minecraft.func_71411_J(Minecraft.java:973)
    at net.minecraft.client.Minecraft.func_99999_d(Minecraft.java:898)
    at net.minecraft.client.main.Main.main(SourceFile:148)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at net.minecraft.launchwrapper.Launch.launch(Launch.java:135)
    at net.minecraft.launchwrapper.Launch.main(Launch.java:28)


A detailed walkthrough of the error, its code path and all known details is as follows:
---------------------------------------------------------------------------------------

-- Head --
Stacktrace:
    at java.nio.Buffer.checkIndex(Unknown Source)
    at java.nio.DirectIntBufferU.get(Unknown Source)
    at net.minecraft.client.renderer.RenderGlobal.func_72712_a(RenderGlobal.java:350)
    at net.minecraft.client.renderer.RenderGlobal.func_72732_a(RenderGlobal.java:294)
    at net.minecraft.client.Minecraft.func_71353_a(Minecraft.java:2216)
    at net.minecraft.client.Minecraft.func_71403_a(Minecraft.java:2146)
    at net.minecraft.client.network.NetHandlerPlayClient.func_147282_a(NetHandlerPlayClient.java:240)
    at net.minecraft.network.play.server.S01PacketJoinGame.func_148833_a(SourceFile:70)
    at net.minecraft.network.play.server.S01PacketJoinGame.func_148833_a(SourceFile:13)
    at net.minecraft.network.NetworkManager.func_74428_b(NetworkManager.java:212)

-- Affected level --
Details:
    Level name: MpServer
    All players: 0 total; []
    Chunk stats: MultiplayerChunkCache: 0, 0
    Level seed: 0
    Level generator: ID 00 - default, ver 1. Features enabled: false
    Level generator options: 
    Level spawn location: World: (8,64,8), Chunk: (at 8,4,8 in 0,0; contains blocks 0,0,0 to 15,255,15), Region: (0,0; contains chunks 0,0 to 31,31, blocks 0,0,0 to 511,255,511)
    Level time: 0 game time, 0 day time
    Level dimension: 0
    Level storage version: 0x00000 - Unknown?
    Level weather: Rain time: 0 (now: false), thunder time: 0 (now: false)
    Level game mode: Game mode: survival (ID 0). Hardcore: false. Cheats: false
    Forced entities: 0 total; []
    Retry entities: 0 total; []
    Server brand: ~~ERROR~~ NullPointerException: null
    Server type: Integrated singleplayer server
Stacktrace:
    at net.minecraft.client.multiplayer.WorldClient.func_72914_a(WorldClient.java:373)
    at net.minecraft.client.Minecraft.func_71396_d(Minecraft.java:2444)
    at net.minecraft.client.Minecraft.func_99999_d(Minecraft.java:927)
    at net.minecraft.client.main.Main.main(SourceFile:148)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at net.minecraft.launchwrapper.Launch.launch(Launch.java:135)
    at net.minecraft.launchwrapper.Launch.main(Launch.java:28)

-- System Details --
Details:
    Minecraft Version: 1.7.10
    Operating System: Windows 8.1 (amd64) version 6.3
    Java Version: 1.8.0_77, Oracle Corporation
    Java VM Version: Java HotSpot(TM) 64-Bit Server VM (mixed mode), Oracle Corporation
    Memory: 168110592 bytes (160 MB) / 522244096 bytes (498 MB) up to 1060372480 bytes (1011 MB)
    JVM Flags: 6 total; -XX:HeapDumpPath=MojangTricksIntelDriversForPerformance_javaw.exe_minecraft.exe.heapdump -Xmx1G -XX:+UseConcMarkSweepGC -XX:+CMSIncrementalMode -XX:-UseAdaptiveSizePolicy -Xmn128M
    AABB Pool Size: 0 (0 bytes; 0 MB) allocated, 0 (0 bytes; 0 MB) used
    IntCache: cache: 0, tcache: 0, allocated: 12, tallocated: 94
    FML: MCP v9.05 FML v7.10.99.99 Minecraft Forge 10.13.4.1558 4 mods loaded, 4 mods active
    States: 'U' = Unloaded 'L' = Loaded 'C' = Constructed 'H' = Pre-initialized 'I' = Initialized 'J' = Post-initialized 'A' = Available 'D' = Disabled 'E' = Errored
    UCHIJAAAA    mcp{9.05} [Minecraft Coder Pack] (minecraft.jar) 
    UCHIJAAAA    FML{7.10.99.99} [Forge Mod Loader] (forge-1.7.10-10.13.4.1558-1.7.10.jar) 
    UCHIJAAAA    Forge{10.13.4.1558} [Minecraft Forge] (forge-1.7.10-10.13.4.1558-1.7.10.jar) 
    UCHIJAAAA    EquivalentExchangeDankEdition{0.2} [EquivalentExchangeDankEdition] (Equivalent Exchange dank edition 1.7.10.zip) 
    GL info: ' Vendor: 'Intel' Version: '4.3.0 - Build 10.18.14.4062' Renderer: 'Intel(R) HD Graphics 5500'
    Launched Version: 1.7.10-Forge10.13.4.1558-1.7.10
    LWJGL: 2.9.1
    OpenGL: Intel(R) HD Graphics 5500 GL version 4.3.0 - Build 10.18.14.4062, Intel
    GL Caps: Using GL 1.3 multitexturing.
Using framebuffer objects because OpenGL 3.0 is supported and separate blending is supported.
Anisotropic filtering is supported and maximum anisotropy is 16.
Shaders are available because OpenGL 2.1 is supported.

    Is Modded: Definitely; Client brand changed to 'fml,forge'
    Type: Client (map_client.txt)
    Resource Packs: [Lvd2K]
    Current Language: Language for fgts (Lvd2K)
    Profiler Position: N/A (disabled)
    Vec3 Pool Size: 0 (0 bytes; 0 MB) allocated, 0 (0 bytes; 0 MB) used
    Anisotropic Filtering: Off (1)

Last seen on 06:57, 17. May 2016
Joined Jul 2015
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Try updating forge
Mon, 04/04/2016 - 14:38

Try updating forge

Last seen on 06:57, 17. May 2016
Joined Jul 2015
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Don't change the version when
Mon, 04/04/2016 - 14:39

Don't change the version when compiling your mod

Last seen on 08:00, 12. Sep 2017
Joined Apr 2016
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
RE:Try updating forge
Mon, 04/04/2016 - 19:07

@#1 To what should I update it? My mod is made for 1.7.10 and I installed the recommended Forge version for 1.7.10...

Last seen on 08:00, 12. Sep 2017
Joined Apr 2016
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
RE:Try updating forge
Mon, 04/04/2016 - 20:41

@#1 I fixed it. Turns out that my vanilla 1.7.10 version was corrupted. Thanks for trying to help me out though.