Minecraft crashing problem... again

Started by Kevaday on Tue, 03/14/2017 - 23:26

Topic category: Bugs and solutions

Last seen on 16:10, 5. May 2019
Joined Aug 2016
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
Minecraft crashing problem... again
Tue, 03/14/2017 - 23:26

This has happened before when I updated mcreator from 1.7.0 to 1.7.1. People helped me fix that problem but now it's happening again and it's really annoying. This started happening (again) when I updated mcreator from 1.7.1 to the new 1.7.5. I imported the old mcr workspace and it popped up. What happens is that when I press play, the normal loading forge window comes up and then it crashes. Here is the crash report:

// Ooh. Shiny.
Time: 3/14/17 7:21 PM
Description: Loading screen debug info
This is just a prompt for computer specs to be printed. THIS IS NOT A ERROR
A detailed walkthrough of the error, its code path and all known details is as follows:
---------------------------------------------------------------------------------------
-- System Details --
Details:
   Minecraft Version: 1.11.2
   Operating System: Windows 8.1 (amd64) version 6.3
   Java Version: 1.8.0_101, Oracle Corporation
   Java VM Version: Java HotSpot(TM) 64-Bit Server VM (mixed mode), Oracle Corporation
   Memory: 671442864 bytes (640 MB) / 854589440 bytes (815 MB) up to 3804758016 bytes (3628 MB)
   JVM Flags: 0 total; 
   IntCache: cache: 0, tcache: 0, allocated: 0, tallocated: 0
   FML: 
   Loaded coremods (and transformers): 
   GL info: ' Vendor: 'ATI Technologies Inc.' Version: '4.5.13464 Compatibility Profile Context 21.19.411.0' Renderer: 'AMD Radeon R7 200 Series'
[19:21:58] [Client thread/INFO] [FML]: MinecraftForge v13.20.0.2228 Initialized
[19:21:58] [Client thread/INFO] [FML]: Replaced 232 ore recipes
[19:21:59] [Client thread/INFO] [FML]: Found 0 mods from the command line. Injecting into mod discoverer
[19:21:59] [Client thread/INFO] [FML]: Searching E:\Games\MCreator175\forge\run\mods for mods
[19:22:00] [Client thread/INFO] [testenvironmentmod]: Mod testenvironmentmod is missing the required element 'name'. Substituting testenvironmentmod
[19:22:00] [Client thread/INFO] [FML]: Forge Mod Loader has identified 5 mods to load
[19:22:00] [Client thread/INFO] [FML]: Attempting connection with missing mods [minecraft, mcp, FML, forge, testenvironmentmod] at CLIENT
[19:22:00] [Client thread/INFO] [FML]: Attempting connection with missing mods [minecraft, mcp, FML, forge, testenvironmentmod] at SERVER
[19:22:01] [Client thread/INFO]: Reloading ResourceManager: Default, FMLFileResourcePack:Forge Mod Loader, FMLFileResourcePack:Minecraft Forge, FMLFileResourcePack:testenvironmentmod
[19:22:01] [Client thread/INFO] [FML]: Processing ObjectHolder annotations
[19:22:01] [Client thread/INFO] [FML]: Found 444 ObjectHolder annotations
[19:22:01] [Client thread/INFO] [FML]: Identifying ItemStackHolder annotations
[19:22:01] [Client thread/INFO] [FML]: Found 0 ItemStackHolder annotations
[19:22:01] [Client thread/INFO] [FML]: Applying holder lookups
[19:22:01] [Client thread/INFO] [FML]: Holder lookups applied
[19:22:01] [Client thread/INFO] [FML]: Applying holder lookups
[19:22:01] [Client thread/INFO] [FML]: Holder lookups applied
[19:22:01] [Client thread/INFO] [FML]: Applying holder lookups
[19:22:01] [Client thread/INFO] [FML]: Holder lookups applied
[19:22:01] [Client thread/INFO] [FML]: Configured a dormant chunk cache size of 0
[19:22:01] [Forge Version Check/INFO] [ForgeVersionCheck]: [forge] Starting version check at http://files.minecraftforge.net/maven/net/minecraftforge/forge/promotio…
[19:22:01] [Forge Version Check/INFO] [ForgeVersionCheck]: [forge] Found status: UP_TO_DATE Target: null
[19:22:01] [Client thread/INFO] [FML]: Applying holder lookups
[19:22:01] [Client thread/INFO] [FML]: Holder lookups applied
[19:22:01] [Client thread/INFO] [FML]: Injecting itemstacks
[19:22:01] [Client thread/INFO] [FML]: Itemstack injection complete
[19:22:02] [Sound Library Loader/INFO]: Starting up SoundSystem...
[19:22:02] [Thread-8/INFO]: Initializing LWJGL OpenAL
[19:22:02] [Thread-8/INFO]: (The LWJGL binding of OpenAL.  For more information, see http://www.lwjgl.org)
[19:22:02] [Thread-8/INFO]: OpenAL initialized.
[19:22:03] [Sound Library Loader/INFO]: Sound engine started
[19:22:04] [Client thread/INFO] [FML]: Max texture size: 16384
[19:22:04] [Client thread/INFO]: Created: 16x16 textures-atlas
[19:22:04] [Client thread/INFO] [FML]: OBJLoader: Domain testenvironmentmod has been added.
[19:22:04] [Client thread/ERROR] [FML]: Fatal errors were detected during the transition from INITIALIZATION to POSTINITIALIZATION. Loading cannot continue
[19:22:04] [Client thread/ERROR] [FML]: 
   States: 'U' = Unloaded 'L' = Loaded 'C' = Constructed 'H' = Pre-initialized 'I' = Initialized 'J' = Post-initialized 'A' = Available 'D' = Disabled 'E' = Errored
   UCHI   minecraft{1.11.2} [Minecraft] (minecraft.jar) 
   UCHI   mcp{9.19} [Minecraft Coder Pack] (minecraft.jar) 
   UCHI   FML{8.0.99.99} [Forge Mod Loader] (forgeSrc-1.11.2-13.20.0.2228.jar) 
   UCHI   forge{13.20.0.2228} [Minecraft Forge] (forgeSrc-1.11.2-13.20.0.2228.jar) 
   UCHE   testenvironmentmod{1.0} [testenvironmentmod] (modid-1.0.jar) 
[19:22:04] [Client thread/ERROR] [FML]: The following problems were captured during this phase
[19:22:04] [Client thread/ERROR] [FML]: Caught exception from testenvironmentmod (testenvironmentmod)
java.lang.ArrayIndexOutOfBoundsException: 3
   at net.minecraft.item.crafting.CraftingManager.addRecipe(CraftingManager.java:233) ~[forgeSrc-1.11.2-13.20.0.2228.jar:?]
   at net.minecraftforge.fml.common.registry.GameRegistry.addShapedRecipe(GameRegistry.java:232) ~[forgeSrc-1.11.2-13.20.0.2228.jar:?]
   at net.minecraftforge.fml.common.registry.GameRegistry.addRecipe(GameRegistry.java:227) ~[forgeSrc-1.11.2-13.20.0.2228.jar:?]
   at mod.mcreator.mcreator_corn.load(mcreator_corn.java:31) ~[modid-1.0.jar:?]
   at mod.mcreator.TestEnvironmentMod.load(TestEnvironmentMod.java:1193) ~[modid-1.0.jar:?]
   at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[?:1.8.0_101]
   at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62) ~[?:1.8.0_101]
   at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) ~[?:1.8.0_101]
   at java.lang.reflect.Method.invoke(Method.java:498) ~[?:1.8.0_101]
   at net.minecraftforge.fml.common.FMLModContainer.handleModStateEvent(FMLModContainer.java:643) ~[forgeSrc-1.11.2-13.20.0.2228.jar:?]
   at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[?:1.8.0_101]
   at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62) ~[?:1.8.0_101]
   at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) ~[?:1.8.0_101]
   at java.lang.reflect.Method.invoke(Method.java:498) ~[?:1.8.0_101]
   at com.google.common.eventbus.EventSubscriber.handleEvent(EventSubscriber.java:74) ~[guava-17.0.jar:?]
   at com.google.common.eventbus.SynchronizedEventSubscriber.handleEvent(SynchronizedEventSubscriber.java:47) ~[guava-17.0.jar:?]
   at com.google.common.eventbus.EventBus.dispatch(EventBus.java:322) ~[guava-17.0.jar:?]
   at com.google.common.eventbus.EventBus.dispatchQueuedEvents(EventBus.java:304) ~[guava-17.0.jar:?]
   at com.google.common.eventbus.EventBus.post(EventBus.java:275) ~[guava-17.0.jar:?]
   at net.minecraftforge.fml.common.LoadController.sendEventToModContainer(LoadController.java:246) ~[forgeSrc-1.11.2-13.20.0.2228.jar:?]
   at net.minecraftforge.fml.common.LoadController.propogateStateMessage(LoadController.java:224) ~[forgeSrc-1.11.2-13.20.0.2228.jar:?]
   at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[?:1.8.0_101]
   at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62) ~[?:1.8.0_101]
   at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) ~[?:1.8.0_101]
   at java.lang.reflect.Method.invoke(Method.java:498) ~[?:1.8.0_101]
   at com.google.common.eventbus.EventSubscriber.handleEvent(EventSubscriber.java:74) ~[guava-17.0.jar:?]
   at com.google.common.eventbus.SynchronizedEventSubscriber.handleEvent(SynchronizedEventSubscriber.java:47) ~[guava-17.0.jar:?]
   at com.google.common.eventbus.EventBus.dispatch(EventBus.java:322) ~[guava-17.0.jar:?]
   at com.google.common.eventbus.EventBus.dispatchQueuedEvents(EventBus.java:304) ~[guava-17.0.jar:?]
   at com.google.common.eventbus.EventBus.post(EventBus.java:275) ~[guava-17.0.jar:?]
   at net.minecraftforge.fml.common.LoadController.distributeStateMessage(LoadController.java:147) [LoadController.class:?]
   at net.minecraftforge.fml.common.Loader.initializeMods(Loader.java:809) [Loader.class:?]
   at net.minecraftforge.fml.client.FMLClientHandler.finishMinecraftLoading(FMLClientHandler.java:343) [FMLClientHandler.class:?]
   at net.minecraft.client.Minecraft.init(Minecraft.java:562) [Minecraft.class:?]
   at net.minecraft.client.Minecraft.run(Minecraft.java:387) [Minecraft.class:?]
   at net.minecraft.client.main.Main.main(Main.java:118) [Main.class:?]
   at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[?:1.8.0_101]
   at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62) ~[?:1.8.0_101]
   at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) ~[?:1.8.0_101]
   at java.lang.reflect.Method.invoke(Method.java:498) ~[?:1.8.0_101]
   at net.minecraft.launchwrapper.Launch.launch(Launch.java:135) [launchwrapper-1.12.jar:?]
   at net.minecraft.launchwrapper.Launch.main(Launch.java:28) [launchwrapper-1.12.jar:?]
   at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[?:1.8.0_101]
   at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62) ~[?:1.8.0_101]
   at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) ~[?:1.8.0_101]
   at java.lang.reflect.Method.invoke(Method.java:498) ~[?:1.8.0_101]
   at net.minecraftforge.gradle.GradleStartCommon.launch(GradleStartCommon.java:97) [start/:?]
   at GradleStart.main(GradleStart.java:26) [start/:?]
[19:22:04] [Client thread/INFO] [STDOUT]: [net.minecraft.init.Bootstrap:printToSYSOUT:600
// Quite honestly, I wouldn't worry myself about that.
Time: 3/14/17 7:22 PM
Description: There was a severe problem during mod loading that has caused the game to fail
net.minecraftforge.fml.common.LoaderExceptionModCrash: Caught exception from testenvironmentmod (testenvironmentmod)
Caused by: java.lang.ArrayIndexOutOfBoundsException: 3
   at net.minecraft.item.crafting.CraftingManager.addRecipe(CraftingManager.java:233)
   at net.minecraftforge.fml.common.registry.GameRegistry.addShapedRecipe(GameRegistry.java:232)
   at net.minecraftforge.fml.common.registry.GameRegistry.addRecipe(GameRegistry.java:227)
   at mod.mcreator.mcreator_corn.load(mcreator_corn.java:31)
   at mod.mcreator.TestEnvironmentMod.load(TestEnvironmentMod.java:1193)
   at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
   at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
   at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
   at java.lang.reflect.Method.invoke(Method.java:498)
   at net.minecraftforge.fml.common.FMLModContainer.handleModStateEvent(FMLModContainer.java:643)
   at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
   at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
   at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
   at java.lang.reflect.Method.invoke(Method.java:498)
   at com.google.common.eventbus.EventSubscriber.handleEvent(EventSubscriber.java:74)
   at com.google.common.eventbus.SynchronizedEventSubscriber.handleEvent(SynchronizedEventSubscriber.java:47)
   at com.google.common.eventbus.EventBus.dispatch(EventBus.java:322)
   at com.google.common.eventbus.EventBus.dispatchQueuedEvents(EventBus.java:304)
   at com.google.common.eventbus.EventBus.post(EventBus.java:275)
   at net.minecraftforge.fml.common.LoadController.sendEventToModContainer(LoadController.java:246)
   at net.minecraftforge.fml.common.LoadController.propogateStateMessage(LoadController.java:224)
   at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
   at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
   at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
   at java.lang.reflect.Method.invoke(Method.java:498)
   at com.google.common.eventbus.EventSubscriber.handleEvent(EventSubscriber.java:74)
   at com.google.common.eventbus.SynchronizedEventSubscriber.handleEvent(SynchronizedEventSubscriber.java:47)
   at com.google.common.eventbus.EventBus.dispatch(EventBus.java:322)
   at com.google.common.eventbus.EventBus.dispatchQueuedEvents(EventBus.java:304)
   at com.google.common.eventbus.EventBus.post(EventBus.java:275)
   at net.minecraftforge.fml.common.LoadController.distributeStateMessage(LoadController.java:147)
   at net.minecraftforge.fml.common.Loader.initializeMods(Loader.java:809)
   at net.minecraftforge.fml.client.FMLClientHandler.finishMinecraftLoading(FMLClientHandler.java:343)
   at net.minecraft.client.Minecraft.init(Minecraft.java:562)
   at net.minecraft.client.Minecraft.run(Minecraft.java:387)
   at net.minecraft.client.main.Main.main(Main.java:118)
   at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
   at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
   at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
   at java.lang.reflect.Method.invoke(Method.java:498)
   at net.minecraft.launchwrapper.Launch.launch(Launch.java:135)
   at net.minecraft.launchwrapper.Launch.main(Launch.java:28)
   at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
   at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
   at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
   at java.lang.reflect.Method.invoke(Method.java:498)
   at net.minecraftforge.gradle.GradleStartCommon.launch(GradleStartCommon.java:97)
   at GradleStart.main(GradleStart.java:26)
A detailed walkthrough of the error, its code path and all known details is as follows:
---------------------------------------------------------------------------------------
-- System Details --
Details:
   Minecraft Version: 1.11.2
   Operating System: Windows 8.1 (amd64) version 6.3
   Java Version: 1.8.0_101, Oracle Corporation
   Java VM Version: Java HotSpot(TM) 64-Bit Server VM (mixed mode), Oracle Corporation
   Memory: 208997776 bytes (199 MB) / 1246232576 bytes (1188 MB) up to 3804758016 bytes (3628 MB)
   JVM Flags: 0 total; 
   IntCache: cache: 0, tcache: 0, allocated: 0, tallocated: 0
   FML: MCP 9.38 Powered by Forge 13.20.0.2228 5 mods loaded, 5 mods active
   States: 'U' = Unloaded 'L' = Loaded 'C' = Constructed 'H' = Pre-initialized 'I' = Initialized 'J' = Post-initialized 'A' = Available 'D' = Disabled 'E' = Errored
   UCHI   minecraft{1.11.2} [Minecraft] (minecraft.jar) 
   UCHI   mcp{9.19} [Minecraft Coder Pack] (minecraft.jar) 
   UCHI   FML{8.0.99.99} [Forge Mod Loader] (forgeSrc-1.11.2-13.20.0.2228.jar) 
   UCHI   forge{13.20.0.2228} [Minecraft Forge] (forgeSrc-1.11.2-13.20.0.2228.jar) 
   UCHE   testenvironmentmod{1.0} [testenvironmentmod] (modid-1.0.jar) 
   Loaded coremods (and transformers): 
   GL info: ' Vendor: 'ATI Technologies Inc.' Version: '4.5.13464 Compatibility Profile Context 21.19.411.0' Renderer: 'AMD Radeon R7 200 Series'
[19:22:05] [Client thread/INFO] [STDOUT]: [net.minecraft.init.Bootstrap:printToSYSOUT:600
AL lib: (EE) alc_cleanup: 1 device not closed
:runClient FAILED
FAILURE: Build failed with an exception.
* What went wrong:
Execution failed for task ':runClient'.
> Process 'command 'E:\Games\MCreator175\jdk64\bin\java.exe'' finished with non-zero exit value -1
BUILD FAILED
* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.
Total time: 48.946 secs
E:\Games\MCreator175\forge>
Task completed with return code 0 in 49280 milliseconds

 

So I hope someone can help me with this (it's really annoying), and thanks

Last seen on 17:01, 19. Mar 2018
Joined Dec 2016
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
I think you need to uninstall
Wed, 03/15/2017 - 14:02

I think you need to uninstall, wait some time and install it again... I think.

Last seen on 17:01, 19. Mar 2018
Joined Dec 2016
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
RE:I think you need to uninstall
Wed, 03/15/2017 - 14:03

@#1 You know. I had this problem too, but with uninstalling, waiting and installing worked for me.

Last seen on 16:10, 5. May 2019
Joined Aug 2016
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
RE:RE:I think you need to uninstall
Wed, 03/15/2017 - 14:33

@#1.1 ok, I'll try it, thanks

Last seen on 16:10, 5. May 2019
Joined Aug 2016
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
RE:RE:RE:I think you need to uninstall
Wed, 03/15/2017 - 14:51

@#1.1.1 So I uninstalled mcreator and reinstalled it. sadly it's still not working :( some1 please help me

Last seen on 13:40, 19. Aug 2019
Joined Apr 2010
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
  • wiki contributor
  • moderator
  • developer
The problem is in mod element
Wed, 03/15/2017 - 20:35

The problem is in mod element called corn, it seems that recipe is invalid. Try to removing recipe and defining it again, or just remake the element corn by removing it and making it again.

Last seen on 16:10, 5. May 2019
Joined Aug 2016
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
RE:The problem is in mod element
Wed, 03/15/2017 - 21:05

@#2 thanks, I'll try that

Last seen on 16:10, 5. May 2019
Joined Aug 2016
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
RE:The problem is in mod element
Wed, 03/15/2017 - 21:51

@#2 It worked! thanks so much for the help :)

Last seen on 20:06, 18. Aug 2019
Joined Mar 2016
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
my do the same 
Wed, 03/15/2017 - 23:38

my do the same