Forge Dependency when exporting is breaking everything!

Started by AOCAWOL on Thu, 02/14/2019 - 01:54

Topic category: Troubleshooting, bugs, and solutions

Last seen on 19:12, 22. Jul 2021
Joined Oct 2014
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Forge Dependency when exporting is breaking everything!
Thu, 02/14/2019 - 01:54

Hi! I noticed in the changelog:

  • Added Minecraft Forge with version tag as mod dependency when exporting

This is making my mod stuck at an older forge and isn't allowing anyone to play it with the newer forge updates. For some reason this didn't affect my 1.5.0 update for my mod but when i released the latest version everyone is getting "You have the wrong forge required" and its making them use 14.23.5.2768 when most mods are using versions more recent forge versions. Again my 1.5.0 update worked completely fine and it was exported using Mcreator 1.8.2 but when I exported version 1.5.1 of my mod this issue appeared everywhere 

In MCreator 1.8.2 we have…
Thu, 02/14/2019 - 20:53

In MCreator 1.8.2 we have added Minecraft Forge version tag as a dependency as many users used MCreator with different versions Minecraft Forge than with the one MCreator used to compile mods. This caused many crashes and errors due to version mismatches. We added this dependency to resolve this issue.

Version 2768 is, in fact, the current recommended version.

Check this issue for more info and a not recommended workaround: https://mcreator.net/tracker/issue/46740

We will add an option to disable this limit and a warning next to it in MCreator 1.8.3.

Last seen on 22:36, 26. May 2020
Joined Aug 2018
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Klemen, good!
Fri, 02/15/2019 - 12:39

Klemen, good!