newer versions being supported/ version secletor

Started by owenpithan on Tue, 09/03/2019 - 22:17

Topic category: Feature requests and ideas for MCreator

Last seen on 19:08, 29. May 2020
Joined Oct 2016
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • Comments:
newer versions being supported/ version secletor
Tue, 09/03/2019 - 22:17

So i like 1.12.2 but it would be nice to have more versions supported

So Would it be possible for a version of mcreator to have eather 1.13 or 1.14 supported, OR just beable to select a version of the game you want to make a mod for (problem solved [or was there even a problem in the first place?]) anyways hope to get a response back :D

 

Last seen on 15:05, 14. Jul 2020
Joined Jun 2019
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • Comments:
In what version specificly?
Wed, 09/04/2019 - 09:53

In what version specificly?

Once we add support for…
Thu, 09/05/2019 - 12:32

Once we add support for newer versions, we will keep support for the other versions and provide a way to switch between them.

Last seen on 15:05, 14. Jul 2020
Joined Jun 2019
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • Comments:
So next mcreator Minecraft…
Fri, 09/06/2019 - 09:15

So next mcreator Minecraft version update you will keep the old ones?

p.s please add support for fabric api and forge api for the newer versions

Fabric API does not support…
Fri, 09/06/2019 - 14:59

Fabric API does not support all the features MCreator uses yet so we will stick to Forge for now.

Last seen on 14:00, 9. May 2020
Joined Apr 2016
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • Comments:
I'm thinking what's going to…
Mon, 09/09/2019 - 01:52

I'm thinking what's going to happen is now that Mojang will release obfuscated code of MC with every major update, every version starting with 1.15 will have MCreator support within a couple of months of release. I can only imagine how annoyed the mods and devs have felt the past two years have been with constant nagging from people who don't comprehend the absolute scope of how large 1.13 was. Java Edition was practically rewritten for the update, so without easy access to the code, making mods was almost impossible. hell, it took almost a year for Optifine to release for 1.13, and 4 months for 1.14. imagine how much of MCreator would have to be too, only longer because Minecraft's code was encrypted up until this week.

Last seen on 23:42, 11. Jul 2020
Joined Mar 2019
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • Comments:
It’s partly true what you…
Mon, 09/09/2019 - 05:09

It’s partly true what you have written. Yes mc was somewhat rewritten again but not everything was. Mojang didn’t encrypt Minecraft, the reason behind optifine was late is bc it’s hard to make a mod that have included shaders system with all the new blocks coming to Minecraft each time. Yeah making mods for Minecraft now is hell of a pin but it’s somewhat always been like that. Yeah thro the years a lot of neat features was removed but it’s still possible to make them just not the way we would like making it. I don’t see how and why mojang should encrypt their game bc the main point of the game was it’s easy to modify.