"Workspace includes elements that don't compile."

Started by Xboy1 on Sun, 10/20/2019 - 21:03

Topic category: Bugs and solutions

Last seen on 23:37, 10. Nov 2019
Joined Oct 2019
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
"Workspace includes elements that don't compile."
Thu, 10/31/2019 - 16:06 (edited)

Everytime I try to export my mod it says "Workspace includes element that don't compile. File not exported" And I don't know how to fix it. Please tell me what it means and how to fix it.

Edit: It's been 11 days and I still don't know how to fix this. I am getting anxious and nobody is responding to the topic. At this point I just need any help at all. It doesn't matter if it works, I just want help.

Things I've tried (In order):

Re-run the  code

Remake the elements

Making a mod with elements that only have green triangles

Reinstialling MCreator (actually didn't work)

Edited by Xboy1 on Thu, 10/31/2019 - 16:06
Last seen on 15:31, 13. Nov 2019
Joined Aug 2019
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
Some mod elements should…
Mon, 10/21/2019 - 12:49

Some mod elements should have a Red triangle indicating that that mod element doesn't compile. This failure can be caused by you having deleted certain things that were still in use by other mod elements.

Last seen on 23:37, 10. Nov 2019
Joined Oct 2019
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
I didn't delete anything…
Mon, 10/21/2019 - 13:47

I didn't delete anything though

Last seen on 23:37, 10. Nov 2019
Joined Oct 2019
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
By the way all the elements…
Mon, 10/21/2019 - 13:49

By the way all the elements have red triangles, but I don't know why. Just so you know.

Last seen on 23:37, 10. Nov 2019
Joined Oct 2019
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
I added tools and those have…
Mon, 10/21/2019 - 15:48

I added tools and those have green triangles

The ore and the item have red triangles

Last seen on 23:37, 10. Nov 2019
Joined Oct 2019
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
I looked on my ruby mod,…
Mon, 10/21/2019 - 17:48

I looked on my ruby mod, which has the most elements, and most of them errored.

The ones that didn't error was

Ruby Sword

Ruby Pickaxe

Ruby Shovel

Ruby Recipe

Ruby Block Recipe

Achievement Trigger

I have a ruby axe and hoe, but those errored, and a ruby nugget recipe.

Last seen on 15:31, 13. Nov 2019
Joined Aug 2019
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
With the provided…
Mon, 10/21/2019 - 22:20

With the provided information, I'm not able to ensure what the exact cause is of those mod elements breaking, but if you deleted and recreated all of the ones that have red, then your mod will compile.

Last seen on 23:37, 10. Nov 2019
Joined Oct 2019
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
I tried it with only one…
Mon, 10/21/2019 - 23:04

I tried it with only one element but it's stil red

Last seen on 13:47, 9. Nov 2019
Joined Aug 2019
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
try regenerating the code
Tue, 10/22/2019 - 01:00

try regenerating the code

Last seen on 23:37, 10. Nov 2019
Joined Oct 2019
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
It gives me the same error
Tue, 10/22/2019 - 15:01

It gives me the same error

Last seen on 13:47, 9. Nov 2019
Joined Aug 2019
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
can you export the project…
Tue, 10/22/2019 - 15:10

can you export the project as a shareable project in the zip file for the dev to take a look