How can I port a 1.12.2 mod to 1.15?

Started by STAT1S on Fri, 05/22/2020 - 16:10

Topic category: Help with MCreator software

Last seen on 19:17, 7. Sep 2020
Joined Apr 2020
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
How can I port a 1.12.2 mod to 1.15?
Fri, 05/22/2020 - 16:10

I am working on a mod called icescape - it has too many features to remake and since 2020.3 dropping support for 1.12.2 I don't want my mod to die.

Last seen on 19:17, 7. Sep 2020
Joined Apr 2020
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Can't we just have 1.12.2…
Fri, 05/22/2020 - 16:12

Can't we just have 1.12.2 support anyway? It's probably not that hard to code anyway for 2020.3 and its unfair that 1.12.2 has been removed after it being at least 50% of the MOTW Mods. There needs to be something that can port Mcreator mods.

Last seen on 19:17, 7. Sep 2020
Joined Apr 2020
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
I don't want to lose my…
Fri, 05/22/2020 - 16:14

I don't want to lose my progress, also what happens when 1.15 becomes "deprecated" - no-one will use it anyway with the release of 1.16 but 1.12.2 was a version the most good mods use.

Last seen on 16:25, 7. Jul 2021
Joined Oct 2020
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
I need to do the opposite. I…
Wed, 03/31/2021 - 23:24

I need to do the opposite. I need to port a 1.15 mod to 1.12 for some rollercoaster scenery around the corner.

Last seen on 16:25, 7. Jul 2021
Joined Oct 2020
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Orrinpants I need to do the…
Wed, 03/31/2021 - 23:26

Orrinpants

I need to do the opposite. I need to port a 1.15 mod to 1.12 for some rollercoaster scenery around the corner.

For now I'll use other mods.