Invalid RAM allocation detected

Started by David14078 on Mon, 01/25/2021 - 17:47

Topic category: Troubleshooting, bugs, and solutions

Last seen on 20:44, 10. Feb 2021
Joined Jul 2019
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Invalid RAM allocation detected
Mon, 01/25/2021 - 17:47

Hey! Everytime I open a workspace, I get shown a message that says: 

Invalid RAM allocation detected!

You have allocated invalid amount for Initial value of RAM dedicated to gradle.
You can change this setting in MCreator's preferences under Gradle options section.

ERROR CODE: JAVA_XMS_INVALID_VALUE [-13]
 

I have already tried every other method from the forum, but it doesn't work, any tips?

 

Last seen on 20:44, 10. Feb 2021
Joined Jul 2019
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Complete error message…
Mon, 01/25/2021 - 17:59

Complete error message copied to clipboard: 

Executing 
    Gradle task: eclipse

Build 
    info: MCreator 2021.1.03117 EAP (03117), forge-1.16.4, 64-bit, 16319 MB, 
    Windows 10, JVM 1.8.0_275, JAVA_HOME: 
    C:\Users\scolm\Desktop\MCreatorEAP20211b03117\jdk

org.gradle.tooling.GradleConnectionException: 
    Could not execute build using connection to Gradle distribution 
    'https://services.gradle.org/distributions/gradle-4.10.3-bin.zip'.

 
      at org.gradle.tooling.internal.consumer.ExceptionTransformer.transform(
ExceptionTransformer.java:55
)

 
      at org.gradle.tooling.internal.consumer.ExceptionTransformer.transform(
ExceptionTransformer.java:29
)

 
      at org.gradle.tooling.internal.consumer.ResultHandlerAdapter.onFailure(
ResultHandlerAdapter.java:43
)

 
      at 
    org.gradle.tooling.internal.consumer.async.DefaultAsyncConsumerActionExecutor$1$1.run(
DefaultAsyncConsumerActionExecutor.java:69
)

 
      at 
    org.gradle.internal.concurrent.ExecutorPolicy$CatchAndRecordFailures.onExecute(
ExecutorPolicy.java:64
)

 
      at org.gradle.internal.concurrent.ManagedExecutorImpl$1.run(
ManagedExecutorImpl.java:48
)

 
      at java.util.concurrent.ThreadPoolExecutor.runWorker(
ThreadPoolExecutor.java:1149
)

 
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(
ThreadPoolExecutor.java:624
)

 
      at 
    org.gradle.internal.concurrent.ThreadFactoryImpl$ManagedThreadRunnable.run(
ThreadFactoryImpl.java:56
)

 
      at java.lang.Thread.run(
Thread.java:748
)

Caused 
    by: org.gradle.api.GradleException: Unable to start the daemon process.

This 
    problem might be caused by incorrect configuration of the daemon.

For 
    example, an unrecognized jvm option is used.

Please 
    refer to the user guide chapter on the daemon at 
    https://docs.gradle.org/4.10.3/userguide/gradle_daemon.html

Please 
    read the following process output to find out more:

-----------------------

Picked 
    up _JAVA_OPTIONS: -Xmx512m

Error 
    occurred during initialization of VM

Initial 
    heap size set to a larger value than the maximum heap size

 
      at org.gradle.launcher.daemon.client.DaemonGreeter.parseDaemonOutput(
DaemonGreeter.java:35
)

 
      at org.gradle.launcher.daemon.client.DefaultDaemonStarter.startProcess(
DefaultDaemonStarter.java:160
)

 
      at org.gradle.launcher.daemon.client.DefaultDaemonStarter.startDaemon(
DefaultDaemonStarter.java:136
)

 
      at 
    org.gradle.launcher.daemon.client.DefaultDaemonConnector.doStartDaemon(
DefaultDaemonConnector.java:212
)

 
      at org.gradle.launcher.daemon.client.DefaultDaemonConnector.startDaemon(
DefaultDaemonConnector.java:206
)

 
      at org.gradle.launcher.daemon.client.DefaultDaemonConnector.connect(
DefaultDaemonConnector.java:130
)

 
      at org.gradle.launcher.daemon.client.DaemonClient.execute(
DaemonClient.java:139
)

 
      at org.gradle.launcher.daemon.client.DaemonClient.execute(
DaemonClient.java:93
)

 
      at 
    org.gradle.tooling.internal.provider.DaemonBuildActionExecuter.execute(
DaemonBuildActionExecuter.java:60
)

 
      at 
    org.gradle.tooling.internal.provider.DaemonBuildActionExecuter.execute(
DaemonBuildActionExecuter.java:41
)

 
      at 
    org.gradle.tooling.internal.provider.LoggingBridgingBuildActionExecuter.execute(
LoggingBridgingBuildActionExecuter.java:58
)

 
      at 
    org.gradle.tooling.internal.provider.LoggingBridgingBuildActionExecuter.execute(
LoggingBridgingBuildActionExecuter.java:37
)

 
      at org.gradle.tooling.internal.provider.ProviderConnection.run(
ProviderConnection.java:180
)

 
      at org.gradle.tooling.internal.provider.ProviderConnection.run(
ProviderConnection.java:124
)

 
      at org.gradle.tooling.internal.provider.DefaultConnection.getModel(
DefaultConnection.java:208
)

 
      at 
    org.gradle.tooling.internal.consumer.connection.CancellableModelBuilderBackedModelProducer.produceModel(
CancellableModelBuilderBackedModelProducer.java:54
)

 
      at 
    org.gradle.tooling.internal.consumer.connection.PluginClasspathInjectionSupportedCheckModelProducer.produceModel(
PluginClasspathInjectionSupportedCheckModelProducer.java:38
)

 
      at 
    org.gradle.tooling.internal.consumer.connection.AbstractConsumerConnection.run(
AbstractConsumerConnection.java:64
)

 
      at 
    org.gradle.tooling.internal.consumer.connection.ParameterValidatingConsumerConnection.run(
ParameterValidatingConsumerConnection.java:49
)

 
      at org.gradle.tooling.internal.consumer.DefaultBuildLauncher$1.run(
DefaultBuildLauncher.java:97
)

 
      at org.gradle.tooling.internal.consumer.DefaultBuildLauncher$1.run(
DefaultBuildLauncher.java:89
)

 
      at 
    org.gradle.tooling.internal.consumer.connection.LazyConsumerActionExecutor.run(
LazyConsumerActionExecutor.java:130
)

 
      at 
    org.gradle.tooling.internal.consumer.connection.CancellableConsumerActionExecutor.run(
CancellableConsumerActionExecutor.java:45
)

 
      at 
    org.gradle.tooling.internal.consumer.connection.ProgressLoggingConsumerActionExecutor.run(
ProgressLoggingConsumerActionExecutor.java:61
)

 
      at 
    org.gradle.tooling.internal.consumer.connection.RethrowingErrorsConsumerActionExecutor.run(
RethrowingErrorsConsumerActionExecutor.java:38
)

 
      at 
    org.gradle.tooling.internal.consumer.async.DefaultAsyncConsumerActionExecutor$1$1.run(
DefaultAsyncConsumerActionExecutor.java:67
)

 
      ... 6 more

TASK 
    EXECUTION FAILED

Task 
    completed in 21 minutes and 5 seconds

Picked      up _JAVA_OPTIONS…
Tue, 01/26/2021 - 10:36

Picked 
    up _JAVA_OPTIONS: -Xmx512m

The solution to this problem and many other problems can be found in our knowledge base: https://mcreator.net/support/knowledgebase Please check the knowledge base before opening a new topic on the issue which has a known fix.

Last seen on 20:44, 10. Feb 2021
Joined Jul 2019
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Sorry, I'm new, and I can't…
Tue, 01/26/2021 - 13:29

Sorry, I'm new, and I can't find the page for my error

Last seen on 20:37, 15. Mar 2022
Joined Mar 2022
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Hey, I just had the same…
Tue, 03/15/2022 - 20:04

Hey, I just had the same problem and the fix is really easy.
step 1 open setting and go to the system
step 2 go to about 
step 3 on the right side you will look after "advanced system settings" click it
step 4 above the "Ok-Cancel-Apply" you can see "environment Variables" Click it
Step 5 in the box where it says "system variables" You will find "_JAVA_OPTIONS" Click it and press edit Under the "system variables" Box
Step 6 change the numbers from 256 or anything lower than 300 and change it to something higher than 300 because that's what Mcreator has as default
Step 7 Click Apply and Ok on all the boxes

And you're done
:D