World Generation Stuck at 100%

Started by Orange Gelatin on

Topic category: Help with MCreator software

Last seen on 15:06, 27. Jun 2021
Joined Jun 2021
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • MCreator plugins:
  • Comments:
World Generation Stuck at 100%

I'm working on a small mod that includes a small chance for a music disc to spawn in a fox's mouth. But when I went to test it, the world would be stuck loading at 100%, and in console it was stuck on around 96%.

The code was a simple (triggered by [entityspawns]) If, does entity exist in a 4 block radius of type [entityfox], do, if, random = 0.05, do, Set item in main hand of entity to 1 [item]

(also sorry I can't just put a picture of the code)

Last seen on 09:42, 5. Sep 2023
Joined May 2021
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • MCreator plugins:
  • Comments:
take the file and load it…
Sun, 06/27/2021 - 06:59

take the file and load it into vanilla minecraft .... %appdata% save folder path way

Last seen on 09:42, 5. Sep 2023
Joined May 2021
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • MCreator plugins:
  • Comments:
And then load it up and quit…
Sun, 06/27/2021 - 07:00

And then load it up and quit. Place file back into your workshop

Last seen on 17:20, 24. May 2024
Joined Oct 2021
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • MCreator plugins:
  • Comments:
wait im confused can you…
Tue, 02/22/2022 - 20:34

wait im confused can you explain that again

I feel like [entityspawns]…
Tue, 02/22/2022 - 21:58

I feel like [entityspawns] trigger is a bit broken, because I also got the same issue with my procedure using it. Removing this procedure made it all back to normal... if this persists in first 2022.1 snapshot, I'd recommend making GitHub bug ticket. I may do one too.

Last seen on 17:20, 24. May 2024
Joined Oct 2021
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • MCreator plugins:
  • Comments:
for me the issue didn't come…
Tue, 02/22/2022 - 22:03

for me the issue didn't come up till today when I added some "player right clicks on entity" and "On loaded entity tick update" procedures and now its broken. so I don't know what my problem is