Achivement/Advancement are bugged

Issue description

Hello,

I created a lot of new achivements/advancements for my mod. I created some new "Advancement Tab", like the vanilla tab, Nether, or Nether, or Minecraft, etc, etc.

I then went into the test environment to see if I had done my things well, and I just do not know why, but I just have the first advancement of each of my new "Advancement Tabs". I did well that my progresses night after one, but I have the game, which does not want to display, and implement them in the game.

I would like you to fix this bug please.

I give you two-three pictures to show you that I really have my correct things.

Otherwise, I LOVE the new version of MCreator. Continue like this, I love you!

Attachment Size
2.PNG61.15 KB 61.15 KB

Issue comments

Submitted by Klemen on Mon, 09/03/2018 - 07:08

Do you trigger the achievements? If they are not triggered, they are not shown as the tree is build as you progress.

For the username change, write to https://www.pylo.co/contact

It also seems if you get it to custom:firstachment for your secand one it wont fire or do anything.

So I should do how in order to be able to make my advancements work, because I'm just doing exactly what it takes, to trigger them when the player does the action, and everything. I do exactly the right thing, but it does not work.

Submitted by Klemen on Tue, 09/04/2018 - 11:58

I will do some testing when I get the time. It sounds like it could be a bug with advancements. What event do you use for triggering them?

I have the same problem. It seems that even commands can't see the advancements

Submitted by Eonaut on Fri, 09/21/2018 - 11:50

Is there a limit on the number of advancements you can have or something?

I'm having an issue where they work, but only up to a certain point. My first 21 advancements all work fine, and no task splits into more than 3 paths, but beyond the last one, they just won't trigger, even though I have tried changing them around and experimenting with different triggers, and dependencies on previous advancements. I don't know if its because I ran out of horizontal room in the advancement tab or what. I can't even seem to get the others to work by making them start their own new tab.

 

Submitted by Klemen on Sat, 10/06/2018 - 14:38

This bug will be fixed in 1.8.1. I am closing this ticket.