Portals not working properly

Published by FireBlox on Sun, 10/21/2018 - 00:54
Upvotes: 0
Issue description

So i'm working on a dimensional exploration mod, Chaotica, and i ran into this problem in MCreator versions 1.7.9 AND 1.8.0: portals to custom dimensions work as they should in creative mode, but in survival mode, they transfer the player to the dimension, but the player does not spawn in the portal. I don't know if i'm the only one with this problem, but it's a bad problem that nobody wants to have. 

Issue comments

I will check this bug and fix it if I manage to replicate it and find a fix.

Submitted by FireBlox on Fri, 10/26/2018 - 01:45

yeah that's the issue i'm having.

This bug most likely won't be fixed in 1.8.1 as I can't locate the cause for this bug. I am postponing this bug for now, but will definitely fix it as soon as possible.

Submitted by FireBlox on Sat, 11/03/2018 - 16:29

ok

i think it is somewhere in the code, but i'm not sure

 

Submitted by FireBlox on Tue, 01/29/2019 - 01:19

so is this being worked on for 1.8.3?

I was not able to find the fix for this yet, as soon as I do this will be fixed.

This bug will be fixed in 1.8.3. I am closing this ticket now.

It was one parameter in EntityPlayerMP that had to be set. It is kinda hacky solution because this parameter is inaccessible by default but it works :D



Donate to MCreator

By donating to developers you can speed up development, as with more resources, we can dedicate more time to MCreator. It is a free project made by developers working on it in their free time.