Issue importing workspace from 1.8.1 to 1.8.2

Submitted by WeswePengu on Mon, 01/28/2019 - 05:17
Issue description

Anyone else having issues importing your mod workspace from 1.8.1 to 1.8.2?

 

For me, its stuck at "converting mod elements" and was stuck for about 2 hours so I tried to force quit the app and when I reopened it and tried to build, everything in the error said:

"error: package testenvironmentmod does not exist"

 

Then when I tried to edit a mod, it said:

"This mod does not have saved instance"

 

I assume both errors occur because I force quit the converting mod elements but like it said, it was 2 hours before I force quit. Also I have a few locked mods but unsure if that matters any.

Attachment Size
Workspace exported from 1.8.11.28 MB 1.28 MB

Issue comments

Submitted by Klemen on Mon, 01/28/2019 - 10:46

Could you run MCreator from your Mac terminal and paste the error log when you import the workspace? Thanks!

Submitted by Klemen on Mon, 01/28/2019 - 18:35

I think I have found the cause and the fix for this bug. I will release 1.8.2 patch soon and I believe it will fix this bug.

Submitted by Klemen on Mon, 01/28/2019 - 19:32

UPDATE 28. 1. 2019, 20:15 CET

There were some bugs found in 1.8.2 so we decided to release a patch update. We have added some new block rotation types in the patch too. If you want this new feature or are having one of the following bugs, consider reinstalling MCreator 1.8.2:

  • [#46623] In some cases, new block UI could get broken
  • [#46631#46639] Import of workspaces with ranged items with custom bullet models failed
  • [#46631#46633] Workspace import on Unix systems did not work
  • In some cases, workspace settings dialog UI could get broken

To apply the patch (fix these bugs), uninstall MCreator 1.8.2, download it again and install it again.