I cant make trees in my custom dimension

Published by MMG on Thu, 03/19/2020 - 12:39
Status
Resolved
Product/platform
MCreator/Windows
Priority
Normal
Issue description

This is another problem of removing structure trees. I made block to spawn as structure in my dimension. Upon generating it should place a tree but it will not due to tick problems I described here: https://mcreator.net/tracker/issue/53474

and here: https://mcreator.net/tracker/issue/51832

Issue comments

Blocks are placed without any ticking, I don't understand what you mean. Please provide more details.

I already talked about this some time ago in posts I given you links to above

You think I remember every single ticket and its details?

These should replace themselfs by structure on tick procedure but it doesnt happens

Why don't you just spawn the structure in the first place, without ticking?

This would work the same way with old tree structures as ticking is not initiated by default.

Since 2020.2 you can enable random tick events which will trigger by default, but not immediately as this would (logically) crash the world, ticks are rather distributed by the tick dispatcher.

Replacing things on world gen is against how the world generator is supposed to work and will cause all sorts of trouble, though, except if you use random tick which is used by things like leaves.

You could use "on structure spawned" event for offsetting.

OR

if your structure is 1x1x1, use schedule block tick update procedure for x,y,z location with "on structure spawned" trigger, but I advise against this approach for reasons explained above.

You are welcome! This is not that well known approach yet so if you stumble upon someone asking this on the forums, you can redirect them on this ticket :)



Donate to MCreator

By donating to developers you can speed up development, as with more resources, we can dedicate more time to MCreator. It is a free project made by developers working on it in their free time.