Help with java compile error!

Started by CanesWonderful… on

Topic category: Help with MCreator software

Last seen on 20:41, 21. Apr 2024
Joined Jan 2021
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • MCreator plugins:
  • Comments:
Help with java compile error!

I know this has been asked a million and one times, but I cant seem to find one with the exact answer I need. I've tried reinstalling, I've tried deleting the caches folder like others have suggested, I've tried restarting, and I've tried using a new workspace, but nothing seems to fix the error, and I only got it after updating, and I don't know how to fix it. So if you could please help, that would be greatly appreciated!

 

Exact error code:

 

Task :compileJava FAILED
C:\Users\djbun\MCreatorWorkspaces\test\src\main\java\net\mcreator\test\TestMod.java:55: error: package TestModItems does not exist TestModItems.REGISTRY.register(bus);
^
1 error
FAILURE: Build failed with an exception.
* What went wrong:
Execution failed for task ':compileJava'.
> Compilation failed; see the compiler error output for details.
* Try:
> Run with --stacktrace option to get the stack trace.
> Run with --info or --debug option to get more log output.
> Run with --scan to get full insights.
* Get more help at https://help.gradle.org
BUILD FAILED in 1s
1 actionable task: 1 executed

BUILD FAILED
Task completed in 2 seconds