Problems

Started by Eonaut on Fri, 05/06/2016 - 12:47

Topic category: Bugs and solutions

Last seen on 23:44, 18. Aug 2019
Joined Apr 2016
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Problems
Fri, 05/06/2016 - 12:47

I have noticed all of these problems with version 1.6.3, and they are really getting annoying:

-all block models other than "block" don't work (ex. stairs, dragon egg, cactus, flower pot, etc.)

-techne models saved as java will not work under anycircumstances. They cause recompilation errors no matter what

-defining my own mob AI (not using AI based on...) always causes recompilation errors

-adding ANYTHING to the nether (new blocks to generate there, new mobs to spawn there, etc.) will crash the game upon entering a nether portal

-making a new biome with custom trees does not work. It only spawns regular vanilla oak trees

-new biomes with a different grass color do not render the new grass color

-new biomes that are part of a new overworld-like dimension generate in the overworld, and there is nothing thet will prevent this 

Please fix these.

Last seen on 17:47, 12. May 2018
Joined Mar 2016
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
for custom trees you need to
Fri, 05/06/2016 - 19:09

for custom trees you need to set on custom trees not vanilla trees

that with grass color is a bug

same with nether portal

mob AI is also bugged

last thing currently can not be fixed

i have same problem with techne

block models have bug

Everything is bugged except problem with trees (but maybe there is a solution for others,i said what i think about it)

Last seen on 23:44, 18. Aug 2019
Joined Apr 2016
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
I did set the trees to use
Fri, 05/06/2016 - 19:48

I did set the trees to use custom blocks, but it still generates vanilla trees

Also, is there a way to fix the nether crashing, even if I remove everything that I would have initially had spawn/generate there?

Last seen on 12:28, 21. Jul 2019
Joined Apr 2016
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Dont tell Mcreator to fix
Fri, 05/06/2016 - 21:20

Dont tell Mcreator to fix there stuff, How about if you want to make a good mod, Learn java.

Last seen on 07:53, 25. Feb 2018
Joined Jan 2016
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
@TheBritishBrotherhood, the
Thu, 05/12/2016 - 02:54

@TheBritishBrotherhood, the sheer fact that you're a member of these forums means that you as well utilize this tool, and therefor don't code your mods in Java.  Why not be more helpful with your posts, or not post at all?  I too am having the aforementioned block issue, and will be following this topic in case a workaround or fix is discovered.