Still Need Help With Caught Exception (I now included gradle log).

Started by Cactus_Awex on Sat, 10/21/2017 - 12:56

Topic category: Help with MCreator software

Last seen on 17:09, 24. Aug 2018
Joined Feb 2017
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Still Need Help With Caught Exception (I now included gradle log).
Sun, 10/22/2017 - 21:00 (edited)

 

I'm close to finishing the first kind of alpha release of my new TNT mod and I have this error. I made a couple posts a while ago but no one saw it (RIP FORUM).  Please note this error doesn't appear in building or cleaning the gradle, just running Minecraft with the mod)

Executing gradle command: clean runClient Microsoft Windows [Version 6.3.9600] (c) 2013 Microsoft Corporation. All rights reserved. C:\Pylo\MCreator175>cd forge C:\Pylo\MCreator175\forge>SET "JAVA_HOME=C:\Pylo\MCreator175\jdk64\" C:\Pylo\MCreator175\forge>SET JAVA_EXE=%JAVA_HOME%\bin\java.exe C:\Pylo\MCreator175\forge>SET PATH=%JAVA_HOME%\bin\;%PATH% C:\Pylo\MCreator175\forge>gradlew -Dorg.gradle.jvmargs="-Xms625m -Xmx2048m" clean runClient This mapping 'snapshot_20161220' was designed for MC 1.11! Use at your own peril. ################################################# ForgeGradle 2.2-SNAPSHOT-d13a6c8 https://github.com/MinecraftForge/ForgeGradle################################################# Powered by MCP unknown http://modcoderpack.com by: Searge, ProfMobius, Fesh0r, R4wk, ZeuX, IngisKahn, bspkrs ################################################# :clean :deobfCompileDummyTask :deobfProvidedDummyTask :sourceApiJava :compileApiJava UP-TO-DATE :processApiResources UP-TO-DATE :apiClasses UP-TO-DATE :sourceMainJava :compileJava :processResources :classes :jar :getVersionJson :extractNatives SKIPPED :extractUserdev UP-TO-DATE :getAssetIndex UP-TO-DATE :getAssets Current status: 117/1196 9% Current status: 243/1196 20% Current status: 450/1196 37% Current status: 751/1196 62% Current status: 972/1196 81% Current status: 1194/1196 99% :makeStart :runClient 2017-10-11 19:13:10,303 WARN Unable to instantiate org.fusesource.jansi.WindowsAnsiOutputStream 2017-10-11 19:13:10,311 WARN Unable to instantiate org.fusesource.jansi.WindowsAnsiOutputStream [19:13:10] [main/INFO] [GradleStart]: Extra: [] [19:13:10] [main/INFO] [GradleStart]: Running with arguments: [--userProperties, {}, --assetsDir, C:/Users/son/.gradle/caches/minecraft/assets, --assetIndex, 1.11, --accessToken{REDACTED}, --version, 1.11.2, --tweakClass, net.minecraftforge.fml.common.launcher.FMLTweaker, --tweakClass, net.minecraftforge.gradle.tweakers.CoremodTweaker] [19:13:10] [main/INFO] [LaunchWrapper]: Loading tweak class name net.minecraftforge.fml.common.launcher.FMLTweaker [19:13:10] [main/INFO] [LaunchWrapper]: Using primary tweak class name net.minecraftforge.fml.common.launcher.FMLTweaker [19:13:10] [main/INFO] [LaunchWrapper]: Loading tweak class name net.minecraftforge.gradle.tweakers.CoremodTweaker [19:13:10] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.fml.common.launcher.FMLTweaker [19:13:10] [main/INFO] [FML]: Forge Mod Loader version 13.20.1.2386 for Minecraft 1.11.2 loading [19:13:10] [main/INFO] [FML]: Java is Java HotSpot(TM) 64-Bit Server VM, version 1.8.0_101, running on Windows 8.1:amd64:6.3, installed at C:\Pylo\MCreator175\jdk64\jre [19:13:10] [main/INFO] [FML]: Managed to load a deobfuscated Minecraft name- we are in a deobfuscated environment. Skipping runtime deobfuscation [19:13:11] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.gradle.tweakers.CoremodTweaker [19:13:11] [main/INFO] [GradleStart]: Injecting location in coremod net.minecraftforge.fml.relauncher.FMLCorePlugin [19:13:11] [main/INFO] [GradleStart]: Injecting location in coremod net.minecraftforge.classloading.FMLForgePlugin [19:13:11] [main/INFO] [LaunchWrapper]: Loading tweak class name net.minecraftforge.fml.common.launcher.FMLInjectionAndSortingTweaker [19:13:11] [main/INFO] [LaunchWrapper]: Loading tweak class name net.minecraftforge.fml.common.launcher.FMLDeobfTweaker [19:13:11] [main/INFO] [LaunchWrapper]: Loading tweak class name net.minecraftforge.gradle.tweakers.AccessTransformerTweaker [19:13:11] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.fml.common.launcher.FMLInjectionAndSortingTweaker [19:13:11] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.fml.common.launcher.FMLInjectionAndSortingTweaker [19:13:11] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.fml.relauncher.CoreModManager$FMLPluginWrapper 2017-10-11 19:13:11,693 WARN Unable to instantiate org.fusesource.jansi.WindowsAnsiOutputStream 2017-10-11 19:13:11,782 WARN Unable to instantiate org.fusesource.jansi.WindowsAnsiOutputStream 2017-10-11 19:13:11,798 WARN Unable to instantiate org.fusesource.jansi.WindowsAnsiOutputStream [19:13:11] [main/ERROR] [FML]: The binary patch set is missing. Either you are in a development environment, or things are not going to work! [19:13:14] [main/ERROR] [FML]: FML appears to be missing any signature data. This is not a good thing [19:13:14] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.fml.relauncher.CoreModManager$FMLPluginWrapper [19:13:14] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.fml.common.launcher.FMLDeobfTweaker [19:13:16] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.gradle.tweakers.AccessTransformerTweaker [19:13:16] [main/INFO] [LaunchWrapper]: Loading tweak class name net.minecraftforge.fml.common.launcher.TerminalTweaker [19:13:16] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.fml.common.launcher.TerminalTweaker [19:13:16] [main/INFO] [LaunchWrapper]: Launching wrapped minecraft {net.minecraft.client.main.Main} [19:13:18] [Client thread/INFO]: Setting user: Player189 [19:13:33] [Client thread/WARN]: Skipping bad option: lastServer: [19:13:33] [Client thread/INFO]: LWJGL Version: 2.9.4 [19:13:37] [Client thread/INFO] [FML]: -- System Details -- Details: Minecraft Version: 1.11.2 Operating System: Windows 8.1 (amd64) version 6.3 Java Version: 1.8.0_101, Oracle Corporation Java VM Version: Java HotSpot(TM) 64-Bit Server VM (mixed mode), Oracle Corporation Memory: 68498056 bytes (65 MB) / 384303104 bytes (366 MB) up to 826277888 bytes (788 MB) JVM Flags: 0 total; IntCache: cache: 0, tcache: 0, allocated: 0, tallocated: 0 FML: Loaded coremods (and transformers): GL info: ' Vendor: 'ATI Technologies Inc.' Version: '4.3.12618 Compatibility Profile Context 13.251.9001.1001' Renderer: 'AMD Radeon HD 8330' [19:13:38] [Client thread/INFO] [FML]: MinecraftForge v13.20.1.2386 Initialized [19:13:38] [Client thread/INFO] [FML]: Replaced 232 ore recipes [19:13:40] [Client thread/INFO] [FML]: Found 0 mods from the command line. Injecting into mod discoverer [19:13:40] [Client thread/INFO] [FML]: Searching C:\Pylo\MCreator175\forge\run\mods for mods [19:13:41] [Thread-6/INFO] [FML]: Using sync timing. 200 frames of Display.update took 276253443 nanos [19:13:44] [Client thread/INFO] [testenvironmentmod]: Mod testenvironmentmod is missing the required element 'name'. Substituting testenvironmentmod [19:13:45] [Client thread/INFO] [FML]: Forge Mod Loader has identified 5 mods to load [19:13:46] [Client thread/INFO] [FML]: Attempting connection with missing mods [minecraft, mcp, FML, forge, testenvironmentmod] at CLIENT [19:13:47] [Client thread/INFO] [FML]: Attempting connection with missing mods [minecraft, mcp, FML, forge, testenvironmentmod] at SERVER [19:13:50] [Client thread/INFO]: Reloading ResourceManager: Default, FMLFileResourcePack:Forge Mod Loader, FMLFileResourcePack:Minecraft Forge, FMLFileResourcePack:testenvironmentmod [19:13:50] [Client thread/INFO] [FML]: Processing ObjectHolder annotations [19:13:50] [Client thread/INFO] [FML]: Found 445 ObjectHolder annotations [19:13:50] [Client thread/INFO] [FML]: Identifying ItemStackHolder annotations [19:13:50] [Client thread/INFO] [FML]: Found 0 ItemStackHolder annotations [19:13:50] [Client thread/INFO] [FML]: Applying holder lookups [19:13:50] [Client thread/INFO] [FML]: Holder lookups applied [19:13:50] [Client thread/INFO] [FML]: Applying holder lookups [19:13:50] [Client thread/INFO] [FML]: Holder lookups applied [19:13:50] [Client thread/INFO] [FML]: Applying holder lookups [19:13:50] [Client thread/INFO] [FML]: Holder lookups applied [19:13:51] [Client thread/INFO] [FML]: Configured a dormant chunk cache size of 0 [19:13:51] [Forge Version Check/INFO] [ForgeVersionCheck]: [forge] Starting version check at http://files.minecraftforge.net/maven/net/minecraftforge/forge/promotion...[19:13:51] [Client thread/INFO] [FML]: Applying holder lookups [19:13:51] [Client thread/INFO] [FML]: Holder lookups applied [19:13:51] [Client thread/INFO] [FML]: Injecting itemstacks [19:13:51] [Client thread/INFO] [FML]: Itemstack injection complete [19:13:52] [Forge Version Check/INFO] [ForgeVersionCheck]: [forge] Found status: UP_TO_DATE Target: null [19:14:03] [Sound Library Loader/INFO]: Starting up SoundSystem... [19:14:03] [Thread-8/INFO]: Initializing LWJGL OpenAL [19:14:03] [Thread-8/INFO]: (The LWJGL binding of OpenAL. For more information, see http://www.lwjgl.org) [19:14:03] [Thread-8/INFO]: OpenAL initialized. [19:14:04] [Sound Library Loader/INFO]: Sound engine started [19:14:19] [Client thread/INFO] [FML]: Max texture size: 16384 [19:14:19] [Client thread/INFO]: Created: 16x16 textures-atlas [19:14:22] [Client thread/INFO] [FML]: OBJLoader: Domain testenvironmentmod has been added. [19:14:22] [Client thread/FATAL] [FML]: Fatal errors were detected during the transition from INITIALIZATION to POSTINITIALIZATION. Loading cannot continue [19:14:22] [Client thread/FATAL] [FML]: States: 'U' = Unloaded 'L' = Loaded 'C' = Constructed 'H' = Pre-initialized 'I' = Initialized 'J' = Post-initialized 'A' = Available 'D' = Disabled 'E' = Errored UCHI minecraft{1.11.2} [Minecraft] (minecraft.jar) UCHI mcp{9.19} [Minecraft Coder Pack] (minecraft.jar) UCHI FML{8.0.99.99} [Forge Mod Loader] (forgeSrc-1.11.2-13.20.1.2386.jar) UCHI forge{13.20.1.2386} [Minecraft Forge] (forgeSrc-1.11.2-13.20.1.2386.jar) UCHE testenvironmentmod{1.0} [testenvironmentmod] (modid-1.0.jar) [19:14:22] [Client thread/FATAL] [FML]: The following problems were captured during this phase [19:14:22] [Client thread/ERROR] [FML]: Caught exception from testenvironmentmod (java.lang.ArrayIndexOutOfBoundsException: 3) AL lib: (EE) alc_cleanup: 1 device not closed [19:14:22] [Client thread/INFO] [STDOUT]: [net.minecraft.init.Bootstrap:printToSYSOUT:600 // Oops. Time: 10/11/17 7:14 PM Description: There was a severe problem during mod loading that has caused the game to fail net.minecraftforge.fml.common.LoaderExceptionModCrash: Caught exception from testenvironmentmod (testenvironmentmod) Caused by: java.lang.ArrayIndexOutOfBoundsException: 3 at net.minecraft.item.crafting.CraftingManager.addRecipe(CraftingManager.java:234) at net.minecraftforge.fml.common.registry.GameRegistry.addShapedRecipe(GameRegistry.java:282) at net.minecraftforge.fml.common.registry.GameRegistry.addRecipe(GameRegistry.java:277) at mod.mcreator.mcreator_strongTNT.load(mcreator_strongTNT.java:63) at mod.mcreator.TestEnvironmentMod.load(TestEnvironmentMod.java:133) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) at java.lang.reflect.Method.invoke(Method.java:498) at net.minecraftforge.fml.common.FMLModContainer.handleModStateEvent(FMLModContainer.java:649) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) at java.lang.reflect.Method.invoke(Method.java:498) at com.google.common.eventbus.EventSubscriber.handleEvent(EventSubscriber.java:74) at com.google.common.eventbus.SynchronizedEventSubscriber.handleEvent(SynchronizedEventSubscriber.java:47) at com.google.common.eventbus.EventBus.dispatch(EventBus.java:322) at com.google.common.eventbus.EventBus.dispatchQueuedEvents(EventBus.java:304) at com.google.common.eventbus.EventBus.post(EventBus.java:275) at net.minecraftforge.fml.common.LoadController.sendEventToModContainer(LoadController.java:253) at net.minecraftforge.fml.common.LoadController.propogateStateMessage(LoadController.java:231) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) at java.lang.reflect.Method.invoke(Method.java:498) at com.google.common.eventbus.EventSubscriber.handleEvent(EventSubscriber.java:74) at com.google.common.eventbus.SynchronizedEventSubscriber.handleEvent(SynchronizedEventSubscriber.java:47) at com.google.common.eventbus.EventBus.dispatch(EventBus.java:322) at com.google.common.eventbus.EventBus.dispatchQueuedEvents(EventBus.java:304) at com.google.common.eventbus.EventBus.post(EventBus.java:275) at net.minecraftforge.fml.common.LoadController.distributeStateMessage(LoadController.java:148) at net.minecraftforge.fml.common.Loader.initializeMods(Loader.java:828) at net.minecraftforge.fml.client.FMLClientHandler.finishMinecraftLoading(FMLClientHandler.java:357) at net.minecraft.client.Minecraft.init(Minecraft.java:562) at net.minecraft.client.Minecraft.run(Minecraft.java:387) at net.minecraft.client.main.Main.main(Main.java:118) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) at java.lang.reflect.Method.invoke(Method.java:498) at net.minecraft.launchwrapper.Launch.launch(Launch.java:135) at net.minecraft.launchwrapper.Launch.main(Launch.java:28) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) at java.lang.reflect.Method.invoke(Method.java:498) at net.minecraftforge.gradle.GradleStartCommon.launch(GradleStartCommon.java:97) at GradleStart.main(GradleStart.java:26) A detailed walkthrough of the error, its code path and all known details is as follows: --------------------------------------------------------------------------------------- -- System Details -- Details: Minecraft Version: 1.11.2 Operating System: Windows 8.1 (amd64) version 6.3 Java Version: 1.8.0_101, Oracle Corporation Java VM Version: Java HotSpot(TM) 64-Bit Server VM (mixed mode), Oracle Corporation Memory: 135647400 bytes (129 MB) / 441450496 bytes (421 MB) up to 826277888 bytes (788 MB) JVM Flags: 0 total; IntCache: cache: 0, tcache: 0, allocated: 0, tallocated: 0 FML: MCP 9.38 Powered by Forge 13.20.1.2386 5 mods loaded, 5 mods active States: 'U' = Unloaded 'L' = Loaded 'C' = Constructed 'H' = Pre-initialized 'I' = Initialized 'J' = Post-initialized 'A' = Available 'D' = Disabled 'E' = Errored UCHI minecraft{1.11.2} [Minecraft] (minecraft.jar) UCHI mcp{9.19} [Minecraft Coder Pack] (minecraft.jar) UCHI FML{8.0.99.99} [Forge Mod Loader] (forgeSrc-1.11.2-13.20.1.2386.jar) UCHI forge{13.20.1.2386} [Minecraft Forge] (forgeSrc-1.11.2-13.20.1.2386.jar) UCHE testenvironmentmod{1.0} [testenvironmentmod] (modid-1.0.jar) Loaded coremods (and transformers): GL info: ' Vendor: 'ATI Technologies Inc.' Version: '4.3.12618 Compatibility Profile Context 13.251.9001.1001' Renderer: 'AMD Radeon HD 8330' [19:14:22] [Client thread/INFO] [STDOUT]: [net.minecraft.init.Bootstrap:printToSYSOUT:600 :runClient FAILED BUILD FAILED FAILURE: Build failed with an exception. * What went wrong: Execution failed for task ':runClient'. > Process 'command 'C:\Pylo\MCreator175\jdk64\bin\java.exe'' finished with non-zero exit value -1 Total time: 2 mins 32.724 secs * Try: Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. C:\Pylo\MCreator175\forge> Task completed with return code 0 in 154636 milliseconds

 

 

If someone could explain this it would help. I have a feeling it has something to do with a variable change in testenviornmentmod.jar but idk.

 

 

Thanks, Cactus_Awex/Awesomex_Gaming.

Edited by Cactus_Awex on Sun, 10/22/2017 - 21:00
Last seen on 22:52, 27. Oct 2017
Joined Nov 2016
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Post the full error and full
Sat, 10/21/2017 - 12:58

Post the full error and full code of the page creating it use pastebin if you need to so people can see what is going on. I have had that error before can't remember on what I think I just deletecd the mod what did it as I created it when MCreator was still building so some things didn't save right.

Last seen on 22:52, 27. Oct 2017
Joined Nov 2016
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
I got this same problem
Mon, 10/23/2017 - 01:27

I got this same problem yesterday it happened when I made a change and hit run or build another item two fast, so it didn't right all the changes right to that mod or a few settings, no error ever, I had to go back a few mods/items to be able to fix it and updating it didn't work I had to remake that elament again.