gradle was not able to access internet ONLY for 1.12.2

Started by legodamen on Thu, 04/29/2021 - 04:27

Topic category: Troubleshooting, bugs, and solutions

Last seen on 05:15, 11. Jun 2021
Joined Jan 2015
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
gradle was not able to access internet ONLY for 1.12.2
Thu, 04/29/2021 - 04:27 (edited)

Now this may seem like a question that has been asked a lot. But this just happened out of nowhere which makes no sense and it's Only for 1.12.2

Let me explain. 

I was using Mcreator yesterday with 1.12.2 for V2020.4 version of Mcreator. My computer had a GPU issue that crashed the minecraft build. Shortly after I decided to retry to launch the build, and it got stuck, it just wouldn't load any further besides the first 2 lines of the console. So I forced stopped it. After that, I decided to do it again and then he gave me an error that "Gradle Was Not Able To Access Internet Connection Mcreator".

After further testing some things out I've concluded that it's ONLY for the version 1.12. And it's not just 2020.4. It happens for 2020.5, and 2021.1. Which makes no sense. Every single time I tried to use 1.12, the build just fails. I did some looking up, and it's not like this is a global Mcreator thing it's just me.

I tried a lot of stuff, I don't got any fire walls of my computer. And even then, that just want to make any sense it again, it worked perfectly fine that just stopped working. 

I restarted my computer a couple times since then. 

And all the other options I seen when I looked up for the "gradle was not able to access internet connection mcreator" Just don't work. 

 

And before you ask, I'm not planning on upgrading my mod to 1.14 and up just yet. I'm planning on doing so later. It's a SMP thing, and were planning on not going back to 1.12 after this anyway. Along with the mod. Because trust me, I want to go to 1.16.5. But I can't just yet because of my mods schedule. 

 

Anyway, I have no idea what's going on, I will send the the console Log. 

 

 

Edited by legodamen on Thu, 04/29/2021 - 04:27
Last seen on 05:15, 11. Jun 2021
Joined Jan 2015
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
The console build feedback. …
Thu, 04/29/2021 - 04:32

The console build feedback. 

Note it doesnt allow me to create new workspaces with 1.12 as well. 

 

Executing Gradle task: build 

Build info: MCreator 2020.4.32115, forge-1.12.2, 64-bit, 16320 MB, Windows 10, JVM 1.8.0_252, JAVA_HOME: G:\minecraft\MCreator\MCreator20204\jdk 

This mapping 'snapshot_20171003' was designed for MC 1.12! Use at your own peril. 

WARNING: You are using an unsupported version of ForgeGradle. 

Please consider upgrading to ForgeGradle 4 and helping in the efforts to get old versions working on the modern toolchain. 

See https://gist.github.com/TheCurle/fe7ad3ede188cbdd15c235cc75d52d4a for more info on contributing. 

################################################# 

         ForgeGradle 2.3-SNAPSHOT-dfb52d0b         

  https://github.com/MinecraftForge/ForgeGradle   

################################################# 

                 Powered by MCP                   

             http://modcoderpack.com              

     by: Searge, ProfMobius, R4wk, ZeuX           

     Fesh0r, IngisKahn, bspkrs, LexManos          

################################################# 

:deobfCompileDummyTask 

:deobfProvidedDummyTask 

:sourceApiJava UP-TO-DATE 

:compileApiJava NO-SOURCE 

:processApiResources NO-SOURCE 

:apiClasses UP-TO-DATE 

:sourceMainJava UP-TO-DATE 

:compileJava FAILED

Last seen on 05:15, 11. Jun 2021
Joined Jan 2015
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
FAILURE: Build failed with…
Thu, 04/29/2021 - 04:32

FAILURE: Build failed with an exception. 

* What went wrong: 

Could not resolve all files for configuration ':forgeGradleMcDeps'. 

 

Could not download commons-io.jar (commons-io:commons-io:2.5) 

Failed to download SHA1 for resource 'https://maven.minecraftforge.net/commons-io/commons-io/2.5/commons-io-2…;

Could not GET 'https://maven.minecraftforge.net/commons-io/commons-io/2.5/commons-io-2…'. Received status code 422 from server: Unprocessable Entity 

 

* Try: 

Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights. 

* Get more help at https://help.gradle.org 

BUILD FAILED in 11s 

5 actionable tasks: 3 executed, 2 up-to-date 

BUILD FAILED 

Task completed in 13724 milliseconds

Logs belong on paste service…
Thu, 04/29/2021 - 07:53
  1. Logs belong on paste service, read https://mcreator.net/wiki/general-publishing-guidelines
  2. Read https://mcreator.net/download/all

Please note that some older versions might not work out of the box. If you intend to use MCreator for Minecraft 1.12.2, use MCreator 2021.1 with the 1.12.2 pluginMCreator 2020.2 and earlier versions will likely no longer work due to changes to the Minecraft Forge server URLs.