The Doom Mod

Published by codyfilms on Thu, 06/16/2016 - 04:12
Share this on:
Downloads:
2795
Upvotes: 6

Jump to downloads

Hello, welcome to my newest mod!!! The Doom Mod!! This mod is based on the new game Doom 4. The Textures of the Mobs and Guns are from, or  have pieces from the real game, +editing!!

This Mod Consist of 1 Armor Set, 13 Mobs, 14  Weapons, and 1 block.

-=+ THANK YOU SO MUCH FOR MOD OF THE WEEK +=-

If you want to support me, subscribe to my YouTube channel:

https://www.youtube.com/channel/UCISsR34AScwH_uOHQ3d8IhA

Also please leave a comment on what you think of the mod.

LET'S GO!!!

Armor:

 

1.) Doom Guy Armor

 

Mobs:

 

1.) Revenant

Difficulty (Medium)

2.) Hell Knight

Difficulty (Easy)

3.) Caco-Demon

Difficulty (Easy)

4.) Imp

Difficulty (Medium)

5.) Lost Soul

Difficulty (Easy)

6.) Mancubus

Difficulty (Medium)

7.) Pinky

Difficulty (Medium)

8.) Spectre

Difficulty (Medium)

9.) Possessed Scientist

Difficulty (Too Easy)

10.) Summoner (doesn't actually summon)

Difficulty (Medium)

11.) Cyber Mancubus

Difficulty (Hard-ish)

12.) Hell Raysor

Difficulty (Medium)

13.) Cyber Spider (Boss)

Difficulty (Hard)

14.) Cyber-Minion

Difficulty (Too Easy)

15.) Doom Guy (Boss)

Difficulty (INSANE)

 

 

Weapons:

 

1.) Combat Shotgun

2.) Super Shotgun

3.) BFG9000

4.) Burst Rifle

5.) Plasma Rifle

6.) Chainsaw

7.) Chaingun

8.) Gauss Cannon

9.) Frag Grenade

10.) Heavy Assult Rifle

11.) Lightning Gun

12.) Rocket Launcher

13.) Siphon Grenade

14.) Static Cannon

 

Blocks

 

1.) Doom Guy Action Figure

2.) Cybernetics Block

 

Items

 

1.) Broken Cybernetics

2.) Cybernetics

 

 

 

Please Report Any Bugs And I'll See What I Can Do!

Project status
In development
Latest supported Minecraft version
1.9.4

I downloaded the version for minecraft 1.10.2, but it says it wants minecraft 1.9.
Am I the only one having this problem, or is this mod's 1.10.2 download still for minecraft 1.9?
I really would like to play in 1.10.2, but I can't because of this problem.