Set redstone power logic state of block

Upvotes: 11
Issue description

It seems that the "set redstone power logic state" procedure block is not working.

If I understood correctly, when the "true" block is connected to it, it should send redstone power signal, however I tried many times in many ways but it seems it just sends no redstone signal at all.

Issue comments

Last time I was testing this, it worked. But the redstone power management of blocks is still practically useless as only all of them at once can have redstone power active. I will check out and potentially further improve redstone support in the future updates.

I tried using some of the redstone procedure blocks before and they broke all entities and stopped the game from saving.

I went to make a switch controller for a minecraft railroad decor mod and this bug made it practically impossible. Any news on when this will be fixed?

We will be removing this feature in its current state in 2020.2 due to being useless in its current form and will be introducing it back down the road in improved version so I am changing this from a bug report to a feature request.



Donate to MCreator

By donating to developers you can speed up development, as with more resources, we can dedicate more time to MCreator. It is a free project made by developers working on it in their free time.